poj1472

Instant Complexity

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 941Accepted: 325

Description

Analyzing the run-time complexity of algorithms is an important tool for designing efficient programs that solve a problem. An algorithm that runs in linear time is usually much faster than an algorithm that takes quadratic time for the same task, and thus should be preferred. 

Generally, one determines the run-time of an algorithm in relation to the `size' n of the input, which could be the number of objects to be sorted, the number of points in a given polygon, and so on. Since determining a formula dependent on n for the run-time of an algorithm is no easy task, it would be great if this could be automated. Unfortunately, this is not possible in general, but in this problem we will consider programs of a very simple nature, for which it is possible. Our programs are built according to the following rules (given in BNF), where < number > can be any non-negative integer: 

< Program > ::= "BEGIN" < Statementlist > "END"
< Statementlist > ::= < Statement > | < Statement > < Statementlist >
< Statement > ::= < LOOP-Statement > | < OP-Statement >
< LOOP-Statement > ::= < LOOP-Header > < Statementlist > "END"
< LOOP-Header > ::= "LOOP" < number > | "LOOP n"
< OP-Statement > ::= "OP" < number >

The run-time of such a program can be computed as follows: the execution of an OP-statement costs as many time-units as its parameter specifies. The statement list enclosed by a LOOP-statement is executed as many times as the parameter of the statement indicates, i.e., the given constant number of times, if a number is given, and n times, if n is given. The run-time of a statement list is the sum of the times of its constituent parts. The total run-time therefore generally depends on n. 

Input

The input starts with a line containing the number k of programs in the input. Following this are k programs which are constructed according to the grammar given above. Whitespace and newlines can appear anywhere in a program, but not within the keywords BEGIN, END, LOOP and OP or in an integer value. The nesting depth of the LOOP-operators will be at most 10.

Output

For each program in the input, first output the number of the program, as shown in the sample output. Then output the run-time of the program in terms of n; this will be a polynomial of degree Y <= 10. Print the polynomial in the usual way, i.e., collect all terms, and print it in the form "Runtime = a*n^10+b*n^9+ . . . +i*n^2+ j*n+k", where terms with zero coefficients are left out, and factors of 1 are not written. If the runtime is zero, just print "Runtime = 0". 
Output a blank line after each test case.

Sample Input

2
BEGIN
  LOOP n
    OP 4
    LOOP 3
      LOOP n
        OP 1
      END
      OP 2
    END
    OP 1
  END
  OP 17
END

BEGIN
  OP 1997 LOOP n LOOP n OP 1 END END
END

Sample Output

Program #1
Runtime = 3*n^2+11*n+17

Program #2
Runtime = n^2+1997

Source

递归+模拟,输出格式很蛋疼。用stack做,wa了n次,参考了http://www.cnblogs.com/ltang/archive/2011/01/17/1937738.html

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>

using namespace std;

char ch[10];
int solve(int* exps)
{
    scanf("%s", ch);
    if(ch[0]=='E')
        return 0;
    if(ch[0]=='B')
        while(solve(exps));
    else if(ch[0]=='L')
    {
        scanf("%s", ch);
        int i,t = -1,texps[11]={0};
        if(ch[0]!='n')
            t=atoi(ch);
        while(solve(texps));
        if(t==-1)   //LOOP n
        {
            for(i=10;i>0;i--)
                texps[i]=texps[i-1];
            texps[0]=0;
        }
        else    //LOOP 123
            for(i=0;i<11;i++)
                texps[i]*=t;
        for(i=0;i<11;i++)
            exps[i]+=texps[i];
    }
    else   //OP
    {
        scanf("%s", ch);
        exps[0]+=atoi(ch);
        return solve(exps);
    }
    return 1;
}
int  main()
{
    int n,i,j,t, exps[11];
    scanf("%d", &n);
    for(i=1;i<=n;i++)
    {
        memset(exps, 0, sizeof(exps));
        solve(exps);
        printf("Program #%d\nRuntime = ", i);
        for(t=0,j=10;j>=0;j--)
            if(exps[j]!=0)
            {
                t++;
                if(t!=1)
                    printf("+");
                if(exps[j]!=1||j==0)
                    printf("%d", exps[j]);
                if(exps[j]!=1&&j>0)
                    printf("*");
                if(j>1)
                    printf("n^%d", j);
                if(j==1)
                    printf("n");
            }
        if(!t)
            printf("0");
        printf("\n\n");
    }
    return 0;
}

转载于:https://www.cnblogs.com/eric-blog/archive/2011/05/28/2060682.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值