[ACM - 深度优先搜索]Oil Deposits

Problem Description

 

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.  

 

Input

 

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.

 

Output

 

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

 

Sample Input

 

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5 
****@
*@@*@
*@**@
@@@*@
@@**@
0 0 

 

Sample Output

 

0
1
2
2

 

Source

 

Mid-Central USA 1997

 

解题思路:

这题没有看解题报告,自己折腾出来的。虽然这题比较简单,但做完后,对Dfs(有了一定的认识,Dfs函数里面包含递归函数,而且把满足返回条件的语句写在最前面,还有对当前变量赋值什么的也写在最前面(把搜索过的地方换成别的变量,标记,避免重复搜索)。本题中DFS搜索了几次,就有几个满足题目要求的Oil Deposits。

代码:

#include <iostream>
using namespace std;

char s[102][102];
int m,n;
int i,j;

void dfs(int x,int y)
{
    if(x<1||x>m||y<1||y>n)
        return  ;
    if(s[x][y]!='@')
        return ;  //把一些返回条件写到最前面
         s[x][y]='*';
    for(int i=-1;i<=1;i++)
        for(int j=-1;j<=1;j++) //8个方向
    {
        dfs(x+i,y+j);
    }
}
int main()
{
    while(cin>>m>>n&&m)
    {
        int c=0;
        for(i=1;i<=m;++i)
            for(j=1;j<=n;j++)
            cin>>s[i][j];

        for(i=1;i<=m;++i)
            for(j=1;j<=n;++j)
        {
            if(s[i][j]=='@')
            {
                dfs(i,j);//深搜
                c++;//DFS了多少次,就有多少个
            }
        }
        cout<<c<<endl;
    }
}


运行截图:

 

转载于:https://www.cnblogs.com/sr1993/p/3697816.html

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值