poj1027

The Same Game

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 3283Accepted: 1256

Description

The game named "Same" is a single person game played on a 10 \Theta 15 board. Each square contains a ball colored red (R), green (G), or blue (B). Two balls belong to the same cluster if they have the same color, and one can be reached from another by following balls of the same color in the four directions up, down, left, and right. At each step of the game, the player chooses a ball whose cluster has at least two balls and removes all balls in the cluster from the board. Then, the board is "compressed" in two steps: 
1. Shift the remaining balls in each column down to fill the empty spaces. The order of the balls in each column is preserved. 
2. If a column becomes empty, shift the remaining columns to the left as far as possible. The order of the columns is preserved. 
For example, choosing the ball at the bottom left corner in the sub-board below causes: 
game.jpg 
The objective of the game is to remove every ball from the board, and the game is over when every ball is removed or when every cluster has only one ball. The scoring of each game is as follows. The player starts with a score of 0. When a cluster of m balls is removed, the player's score increases by (m-2)^2 . A bonus of 1000 is given if every ball is removed at the end of the game. 
You suspect that a good strategy might be to choose the ball that gives the largest possible cluster at each step, and you want to test this strategy by writing a program to simulate games played using this strategy. If there are two or more balls to choose from, the program should choose the leftmost ball giving the largest cluster. If there is still a tie, it should choose the bottommost ball of these leftmost balls.

Input

You will be given a number of games in the input. The first line of input contains a positive integer giving the number of games to follow. The initial arrangement of the balls of each game is given one row at a time, from top to bottom. Each row contains 15 characters, each of which is one of "R", "G", or "B", specifying the colors of the balls in the row from left to right. A blank line precedes each game.

Output

For each game, print the game number, followed by a new line, followed by information about each move, followed by the final score. Each move should be printed in the format: 
Move x at (r,c): removed b balls of color C, got s points. 
where x is the move number, r and c are the row number and column number of the chosen ball, respectively. The rows are numbered from 1 to 10 from the bottom, and columns are numbered from 1 to 15 from the left. b is the number of balls in the cluster removed. C is one of "R", "G", or "B", indicating the color of the balls removed. s is the score for this move. The score does not include the 1000 point bonus if all the balls are removed after the move. 
The final score should be reported as follows: 
Final score: s, with b balls remaining. 
Insert a blank line between the output of each game. Use the plural forms "balls" and "points" even if the corresponding value is 1.

Sample Input

3 
RGGBBGGRBRRGGBG 
RBGRBGRBGRBGRBG
RRRRGBBBRGGRBBB
GGRGBGGBRRGGGBG
GBGGRRRRRBGGRRR
BBBBBBBBBBBBBBB
BBBBBBBBBBBBBBB
RRRRRRRRRRRRRRR
RRRRRRGGGGRRRRR
GGGGGGGGGGGGGGG

RRRRRRRRRRRRRRR
RRRRRRRRRRRRRRR
GGGGGGGGGGGGGGG
GGGGGGGGGGGGGGG
BBBBBBBBBBBBBBB
BBBBBBBBBBBBBBB
RRRRRRRRRRRRRRR
RRRRRRRRRRRRRRR 
GGGGGGGGGGGGGGG
GGGGGGGGGGGGGGG

RBGRBGRBGRBGRBG
BGRBGRBGRBGRBGR
GRBGRBGRBGRBGRB
RBGRBGRBGRBGRBG
BGRBGRBGRBGRBGR
GRBGRBGRBGRBGRB
RBGRBGRBGRBGRBG
BGRBGRBGRBGRBGR
GRBGRBGRBGRBGRB
RBGRBGRBGRBGRBG

Sample Output

Game 1: 

Move 1 at (4,1): removed 32 balls of color B, got 900 points. 
Move 2 at (2,1): removed 39 balls of color R, got 1369 points. 
Move 3 at (1,1): removed 37 balls of color G, got 1225 points. 
Move 4 at (3,4): removed 11 balls of color B, got 81 points. 
Move 5 at (1,1): removed 8 balls of color R, got 36 points. 
Move 6 at (2,1): removed 6 balls of color G, got 16 points. 
Move 7 at (1,6): removed 6 balls of color B, got 16 points. 
Move 8 at (1,2): removed 5 balls of color R, got 9 points. 
Move 9 at (1,2): removed 5 balls of color G, got 9 points. 
Final score: 3661, with 1 balls remaining. 

Game 2: 

Move 1 at (1,1): removed 30 balls of color G, got 784 points. 
Move 2 at (1,1): removed 30 balls of color R, got 784 points. 
Move 3 at (1,1): removed 30 balls of color B, got 784 points. 
Move 4 at (1,1): removed 30 balls of color G, got 784 points. 
Move 5 at (1,1): removed 30 balls of color R, got 784 points. 
Final score: 4920, with 0 balls remaining. 

Game 3: 

Final score: 0, with 150 balls remaining. 

Source


 http://blog.sina.com.cn/s/blog_6635898a0100lx20.html

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
using namespace std;
const int Max = 20;

int m, row, col, cou;
char color, map[Max][Max];
bool vis[Max][Max];
int dr[4] = {-1, 0, 0, 1};
int dc[4] = {0, -1, 1, 0};

bool inmap(int r, int c){
    if(r >= 0 && r < 10 && c >= 0 && c < 15)
        return true;
    return false;
}

void dfs(int r, int c, int type){
    vis[r][c] = true;
    for(int i = 0; i < 4; i ++){
        int rr = r + dr[i];
        int cc = c + dc[i];
        if(inmap(rr, cc) && !vis[rr][cc] && map[r][c] != '0' && map[rr][cc] == map[r][c])
            dfs(rr, cc, type);
    }
    if(type == 0) cou ++;
    else map[r][c] = '0';
}

bool find(){       //  寻找最多相连颜色的位置和数量。
    int r, c;
    memset(vis, 0, sizeof(vis));
    m = 0;
    for(c = 0; c < 15; c ++)
        for(r = 9; r >= 0; r --)
            if(!vis[r][c]){
                cou = 0;
                dfs(r, c, 0);
                if(cou > m){
                    m = cou; row = r; col = c;
                    color = map[r][c];
                }
            }
    return m >= 2;
}

void remove(){     //  移走这次删除的所有球。
    memset(vis, 0, sizeof(vis));
    dfs(row, col, 1);
}

void shift(){      //  按规则压缩剩下的所有球。
    int r, c, k;
    for(c = 0; c < 15; c ++){       //  每一竖行向下压缩。
        r = 9;
        while(map[r][c] != '0' && r >= 0) r --;
        if(r < 0) continue;
        k = r - 1;
        while(k >= 0){
            if(map[k][c] == '0') k --;
            else{
                map[r][c] = map[k][c];
                map[k][c] = '0';
                r --; k --;
            }
        }
    }
    for(c = 0; c < 15; c ++)        //  对全部空的竖行,右边的所有球向左移动压缩满。
        if(map[9][c] == '0'){
            k = c + 1;
            while(map[9][k] == '0') k ++;
            if(k >= 15) break;
            r = 9;
            while(map[r][k] != '0' && r >= 0){
                map[r][c] = map[r][k];
                map[r][k] = '0';
                r --;
            }
        }
}

int main(){
    int testCase, t, i;
    scanf("%d", &testCase);
    for(t = 1; t <= testCase; t ++){
        for(i = 0; i < 10; i ++)
            scanf("%s", map[i]);
        int k = 1, num = 0, sum = 0;
        printf("Game %d:\n\n", t);
        while(find()){
            remove();
            int point = pow(m-2.0, 2.0);
            printf("Move %d at (%d,%d): removed %d balls of color %c, got %d points.\n",
                k ++, 10-row, 1+col, m, color, point);
            num += m;
            sum += point;
            shift();
        }
        if(num == 150) printf("Final score: %d, with 0 balls remaining.\n\n", 1000+sum);
        else printf("Final score: %d, with %d balls remaining.\n\n", sum, 150-num);
    }
    return 0;
}

转载于:https://www.cnblogs.com/eric-blog/archive/2011/05/28/2060721.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值