upc组队赛16 WTMGB【模拟】

WTMGB

题目链接

题目描述

YellowStar is very happy that the FZU Code Carnival is about to begin except that he has to prepare problems for it. Because the statement of each problem is written in English!
YellowStar types the statements slowly witb high error rate. You must notice that the previous word ’witb’ is wrong(the correct word is ’with’). But YellowStar feels too tired, so he thinks a word is the same as another word if the character at each position of the word is adjacent to the corresponding character of the other word on the keyboard. The keyboard is shown in the figure below:

When two characters on ther keyboard have intersections, they are considered to be adjacent. For example,’S’ is adjacent to ’W’,’E’,’A’,’D’,’Z’ and ’X’.
Now YellowStar asks you to write a program to check whether two strings are the same. Print ’Yes’ if they are the same, and ’No’ otherwise(without the quotes).

输入

Input is given from Standard Input in the following format:
S1
S2
Constraints
1 ≤ | S1 | = | S2 | ≤ 103
S1 and S2 consist only of upper-case English letters.

输出

Print one line denotes the answer.

样例输入

S
U

样例输出

No

题解

简单模拟 但我写的太长太慢了

代码

#include<bits/stdc++.h>
using namespace std;
#define rep(i,a,n) for(int i=a;i<n;i++)
#define scac(x) scanf("%c",&x)
#define sca(x) scanf("%d",&x)
#define sca2(x,y) scanf("%d%d",&x,&y)
#define sca3(x,y,z) scanf("%d%d%d",&x,&y,&z)
#define scl(x) scanf("%lld",&x)
#define scl2(x,y) scanf("%lld%lld",&x,&y)
#define scl3(x,y,z) scanf("%lld%lld%lld",&x,&y,&z)
#define pri(x) printf("%d\n",x)
#define pri2(x,y) printf("%d %d\n",x,y)
#define pri3(x,y,z) printf("%d %d %d\n",x,y,z)
#define prl(x) printf("%lld\n",x)
#define prl2(x,y) printf("%lld %lld\n",x,y)
#define prl3(x,y,z) printf("%lld %lld %lld\n",x,y,z)
#define ll long long
#define LL long long
inline ll read(){ll x=0,f=1;char ch=getchar();
while(ch<'0'||ch>'9'){if(ch=='-')f=-1;ch=getchar();}
while(ch>='0'&&ch<='9'){x=x*10+ch-'0';ch=getchar();}
return x*f;}
#define read read()
#define pb push_back
#define mp make_pair
#define P pair<int,int>
#define PLL pair<ll,ll>
#define PI acos(1.0)
#define eps 1e-6
#define inf 1e17
#define INF 0x3f3f3f3f
#define MOD 998244353
#define mod 1e9+7
#define N 1000005
const int maxn=2000005;
string s1,s2;
int e[28][28];
void add(int a,int b)
{
  e[a][b] = 1;
  e[b][a] = 1;
}
void Init()
{
  add('Q' - 'A','W' - 'A');
  add('Q' - 'A','A' - 'A');
  add('W' - 'A','E' - 'A');
  add('W' - 'A','S' - 'A');
  add('W' - 'A','A' - 'A');
  add('E' - 'A','S' - 'A');
  add('E' - 'A','R' - 'A');
  add('E' - 'A','D' - 'A');
  add('R' - 'A','T' - 'A');
  add('R' - 'A','F' - 'A');
  add('R' - 'A','D' - 'A');
  add('T' - 'A','Y' - 'A');
  add('T' - 'A','G' - 'A');
  add('T' - 'A','F' - 'A');
  add('Y' - 'A','U' - 'A');
  add('Y' - 'A','H' - 'A');
  add('Y' - 'A','G' - 'A');
  add('U' - 'A','J' - 'A');
  add('U' - 'A','I' - 'A');
  add('U' - 'A','H' - 'A');
  add('I' - 'A','O' - 'A');
  add('I' - 'A','K' - 'A');
  add('I' - 'A','J' - 'A');
  add('O' - 'A','K' - 'A');
  add('O' - 'A','L' - 'A');
  add('O' - 'A','P' - 'A');
  add('P' - 'A','L' - 'A');
  add('A' - 'A','S' - 'A');
  add('A' - 'A','Z' - 'A');
  add('S' - 'A','D' - 'A');
  add('S' - 'A','X' - 'A');
  add('S' - 'A','Z' - 'A');
  add('D' - 'A','F' - 'A');
  add('D' - 'A','C' - 'A');
  add('D' - 'A','X' - 'A');
  add('F' - 'A','G' - 'A');
  add('F' - 'A','V' - 'A');
  add('F' - 'A','C' - 'A');
  add('G' - 'A','H' - 'A');
  add('G' - 'A','B' - 'A');
  add('G' - 'A','V' - 'A');
  add('H' - 'A','J' - 'A');
  add('H' - 'A','N' - 'A');
  add('H' - 'A','B' - 'A');
  add('J' - 'A','K' - 'A');
  add('J' - 'A','M' - 'A');
  add('J' - 'A','N' - 'A');
  add('K' - 'A','L' - 'A');
  add('K' - 'A','M' - 'A');
  add('Z' - 'A','X' - 'A');
  add('X' - 'A','C' - 'A');
  add('C' - 'A','V' - 'A');
  add('V' - 'A','B' - 'A');
  add('B' - 'A','N' - 'A');
  add('N' - 'A','M' - 'A');
}
int main()
{
  string s1,s2;
  for(int i = 0; i<26;i++)
  {
    e[i][i] = 1;
  }
  Init();
  cin >>s1 >> s2;
  int flag =1 ;
  for(int i = 0;i <s1.length();i++)
  {
    if(e[s1[i] - 'A'][s2[i] - 'A']) continue;
    else{
      flag = 0;
      break;
    }
  }
  if(flag ) cout << "Yes" <<endl;
  else cout <<"No" <<endl;
  return 0;
}
/*
5
1 6 9 8 3
2 5 6 7 9
*/

转载于:https://www.cnblogs.com/llke/p/10809707.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值