HDU Problem 5480 Conturbatio

Conturbatio

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 981    Accepted Submission(s): 442

Problem Description
There are many rook on a chessboard, a rook can attack the row and column it belongs, including its own place.

There are also many queries, each query gives a rectangle on the chess board, and asks whether every grid in the rectangle will be attacked by any rook?
 

 

Input
The first line of the input is a integer  T, meaning that there are  T test cases.

Every test cases begin with four integers  n,m,K,Q.
K is the number of Rook,  Q is the number of queries.

Then  K lines follow, each contain two integers  x,y describing the coordinate of Rook.

Then  Q lines follow, each contain four integers  x1,y1,x2,y2 describing the left-down and right-up coordinates of query.

1n,m,K,Q100,000.

1xn,1ym.

1x1x2n,1y1y2m.
 

 

Output
For every query output "Yes" or "No" as mentioned above.
 

 

Sample Input
2 2 2 1 2 1 1 1 1 1 2 2 1 2 2 2 2 2 1 1 1 1 2 2 1 2 2
 

 

Sample Output
Yes No Yes
Hint
Huge input, scanf recommended.
 

 

Source
 

 

Recommend
hujie   |   We have carefully selected several similar problems for you:   5867  5866  5865  5864  5863 
 
很水的一道题。如果棋盘上的一个点会受到攻击,那么他所在的列和行上最少有一个车,也就是说一个车就确定了一行一列。用两个数组存放从第一行(列)到当前行(列)有多少行(列)会受到攻击就可以了。
#include <map>
#include <set>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
#include <iostream>
#include <stack>
#include <cmath>
#include <vector>
#include <cstdlib>
using namespace std;
//typedef long long LL;
//typedef __int64 Int;
typedef pair<int,int> paii;
const int INF = 0x3f3f3f3f;
const double ESP = 1e-5;
const double Pi = acos(-1);
const int MOD = 1e9+5;
const int MAXN = 100000 + 10;
int visx[MAXN], visy[MAXN];
int main() {
    int T, m, n, K, Q, a1, b1, a2, b2, a, b;
    scanf("%d", &T);
    while (T--) {
        memset(visx, 0, sizeof(visx));
        memset(visy, 0, sizeof(visy));
        scanf("%d%d%d%d", &n, &m, &K, &Q);
        for (int i = 0; i < K; i++) {
            scanf("%d%d", &a, &b);
            visx[a] = visy[b] = 1;
        }
        for (int i = 1; i <= n; i++) {
            visx[i] += visx[i - 1];
        }
        for (int i = 1; i <= m; i++) {
            visy[i] += visy[i - 1];
        }
        while (Q--) {
            scanf("%d%d%d%d", &a1, &b1, &a2, &b2);
            if (visx[a2] - visx[a1 - 1] == (a2 - a1 + 1))
                printf("Yes\n");
            else if (visy[b2] - visy[b1 - 1] == (b2 - b1 + 1))
                printf("Yes\n");
            else printf("No\n");
        }
    }
    return 0;
}

 

 

 

转载于:https://www.cnblogs.com/cniwoq/p/6770807.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值