A1034 Head of a Gang (30 分)(树的DFS)(邻接矩阵)(难)

One way that the police finds the head of a gang is to check people's phone calls. If there is a phone call between A and B, we say that A and B is related. The weight of a relation is defined to be the total time length of all the phone calls made between the two persons. A "Gang" is a cluster of more than 2 persons who are related to each other with total relation weight being greater than a given threthold K. In each gang, the one with maximum total weight is the head. Now given a list of phone calls, you are supposed to find the gangs and the heads.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive numbers N and K (both less than or equal to 1000), the number of phone calls and the weight threthold, respectively. Then N lines follow, each in the following format:

Name1 Name2 Time

where Name1 and Name2 are the names of people at the two ends of the call, and Time is the length of the call. A name is a string of three capital letters chosen from A-Z. A time length is a positive integer which is no more than 1000 minutes.

Output Specification:

For each test case, first print in a line the total number of gangs. Then for each gang, print in a line the name of the head and the total number of the members. It is guaranteed that the head is unique for each gang. The output must be sorted according to the alphabetical order of the names of the heads.

Sample Input 1:

8 59
AAA BBB 10
BBB AAA 20
AAA CCC 40
DDD EEE 5
EEE DDD 70
FFF GGG 30
GGG HHH 20
HHH FFF 10

Sample Output 1:

2
AAA 3
GGG 3

Sample Input 2:

8 70
AAA BBB 10
BBB AAA 20
AAA CCC 40
DDD EEE 5
EEE DDD 70
FFF GGG 30
GGG HHH 20
HHH FFF 10

Sample Output 2:

0

题意:

给出若干人之间的通话时间(视为无向边),按照这些通话将他们分为若干组,每个组的边权设为组内的所有通话长度之和,而每个人的点权设为该人参与通话的长度之和。现在给定一个阈值K,且只要有一个组的总边权超过K,并满足人员数超过2,则将该组视为“犯罪团伙(Gang)”,而该组内权最大的人视为头目。

输入:第一行:N 电话次数 K 阈值

接着N行分别给出通话的两人姓名以及通话时间

输出:Gang的个数,并按照姓名字典序输出Gang头目以及成员个数

思路:

题目给出姓名之间的关系,第一个问题:将姓名与编号联系起来?采用map,将两个相互对应,这样方便后面边权值与点权值的统计

难点:题中涉及的量较多,难以联系起来?

可以看出,题中寻找满足:总边权超过K,并满足人员数超过2的组,要输出head和成员个数?将当前访问编号、头目、成员编号、总边权均传入DFS函数中,在遍历过程中不断更新

输出head和成员个数?采用map<string, int> Gang; 犯罪头目->该团伙人数,非常方便建立联系

图的存储结构?为了方便计算边权值,而且题中给的点、权值的关系,采用邻接矩阵

注意:

  1. 由于通话记录最多1000条,因此不同的人可能有2000,数组大小设为2010,否则会有一组数据段错误
#include <iostream>
#include <string>
#include <map>
using namespace std;
const int maxn = 2010;
int n, k;
map<string, int> stringToInt;   //姓名->编号
map<int, string> intToString;
map<string, int> Gang;          //犯罪头目->该团伙人数(用于存储输出)
int G[maxn][maxn] = {0};        //采用邻接矩阵存储该无向图,G[i][j]存储对应的边权值
int weight[maxn] = {0};         //存储点权值
bool vis[maxn] = {false};
int numPerson = 0;              //记录总人数,change函数中作为str的对应编号

//返回名字str对应的编号
int change(string str){
    if(stringToInt.find(str) != stringToInt.end()){     //如果str已经出现过
        return stringToInt[str];
    }
    else{
        stringToInt[str] = numPerson;
        intToString[numPerson] = str;
        return numPerson++;             //返回对应编号,并且更新总人数
    }
}

//DFS访问单个连通块
//当前访问编号、头目、成员编号、总边权
void DFS(int nowVisit, int& head, int& numMember, int& totalValue){
    numMember++;
    vis[nowVisit] = true;
    if(weight[nowVisit] > weight[head]){
        head = nowVisit;
    }
    for(int i = 0; i < numPerson; i++){     //枚举所有人,从nowVisit到所有节点进行遍历
        if(G[nowVisit][i] > 0){             //如果从nowVisit可以到达i
            totalValue += G[nowVisit][i];
            G[nowVisit][i] = G[i][nowVisit] = 0;    //删除这条边,防止回头
            if(vis[i] == false){
                DFS(i, head, numMember, totalValue);
            }
        }
    }
}

void DFSTrave(){
    for(int i = 0; i < numPerson; i++){
        if(vis[i] == false){
            int head = i, numMember = 0, totalValue = 0;    //头目、成员数、总边权,传入DFS函数中
            DFS(i, head, numMember, totalValue);            //遍历i所在的连通块
            //如果成员数大于2且总边权大于k
            if(numMember > 2 && totalValue > k){
                Gang[intToString[head]] = numMember;        //编号为head对应的头目姓名的成员数为numMember
            }
        }
    }
}

int main(){
    cin >> n >> k ;
    int w;
    string str1, str2;
    for(int i = 0; i < n; i++){
        cin >> str1 >> str2 >> w;
        int id1 = change(str1);
        int id2 = change(str2);
        weight[id1] += w;
        weight[id2] += w;
        G[id1][id2] += w;
        G[id2][id1] += w;
    }
    DFSTrave();
    cout << Gang.size() << endl;
    for(map<string, int>::iterator it = Gang.begin(); it != Gang.end(); it++){
        cout << it->first << " " << it->second << endl;
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值