A1033 To Fill or Not to Fill (25 分)(加油站问题)(贪心)(难)

With highways available, driving a car from Hangzhou to any other city is easy. But since the tank capacity of a car is limited, we have to find gas stations on the way from time to time. Different gas station may give different price. You are asked to carefully design the cheapest route to go.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 positive numbers: C​max​​ (≤ 100), the maximum capacity of the tank; D (≤30000), the distance between Hangzhou and the destination city; D​avg​​ (≤20), the average distance per unit gas that the car can run; and N (≤ 500), the total number of gas stations. Then N lines follow, each contains a pair of non-negative numbers: P​i​​, the unit gas price, and D​i​​ (≤D), the distance between this station and Hangzhou, for i=1,⋯,N. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the cheapest price in a line, accurate up to 2 decimal places. It is assumed that the tank is empty at the beginning. If it is impossible to reach the destination, print The maximum travel distance = X where X is the maximum possible distance the car can run, accurate up to 2 decimal places.

Sample Input 1:

50 1300 12 8
6.00 1250
7.00 600
7.00 150
7.10 0
7.20 200
7.50 400
7.30 1000
6.85 300

Sample Output 1:

749.17

Sample Input 2:

50 1300 12 2
7.10 0
7.00 600

Sample Output 2:

The maximum travel distance = 1200.00
#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;

const int maxn = 510;
const int inf = 100000000;

struct station {
    double price, dis;
}st[maxn];

bool cmp(station a, station b) {
    return a.dis < b.dis;
}

int main() {
    int n;
    double maxc, d, davg;
    scanf("%lf%lf%lf%d", &maxc, &d, &davg, &n);
    for(int i = 0; i < n; i++) {
        scanf("%lf%lf", &st[i].price, &st[i].dis);
    }
    st[n].price = 0;
    st[n].dis = d;
    sort(st, st + n, cmp);
    if(st[0].dis != 0) {
        printf("The maximum travel distance = 0.00\n");
    } else {
        int now = 0;    //当前所处的加油站编号
        //总花费、当前油量、满油行驶距离
        double ans = 0, nowTank = 0, maxm = maxc * davg;
        //每次循环选出下一个需要到达的加油站
        while(now < n) {
            int k = -1;
            double minPrice = inf;
            for(int i = now + 1; i <= n && st[i].dis - st[now].dis <= maxm; i++) {  //在满油状态下可以到达的加油站中寻找
                if(st[i].price < minPrice) {    //寻找这些加油站中价钱最低的那个
                    minPrice = st[i].price;
                    k = i;
                    if(minPrice < st[now].price) {      //如果找到的加油站比当前价格还低
                        break;
                    }
                }
            }
            if(k == -1) {   //满油状态下无法找到加油站,退出循环
                break;
            }
            double need = (st[k].dis - st[now].dis) / davg;     //到达选出的加油站需要的油量
            if(minPrice < st[now].price) {          //如果选出的加油站k低于当前加油站
                //只卖足够到达k的油
                if(nowTank < need) {
                    ans += (need - nowTank) * st[now].price;
                    nowTank = 0;        //到达k后,油箱清空
                } else {
                    nowTank -= need;
                }
            } else {        //如果选出的加油站k高于当前价格
                ans += (maxc - nowTank) * st[now].price;    //在当前加油站加满油
                nowTank = maxc - need;                  //到达k之后剩余油量减去用掉的油
            }
            now = k;        //到达k,进行下一次循环
        }
        if(now == n) {      //能够到达终点
            printf("%.2f\n", ans);
        } else {            //不能到达终点
            printf("The maximum travel distance = %.2f\n", st[now].dis + maxm);
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值