java判捕获e异常类型_jmu-Java-06异常-多种类型异常的捕获

女朋友刚刚使用pta提交java不太熟练,我也就给她简单的写了几个代码以做示范。

如果try块中的代码有可能抛出多种异常,且这些异常之间可能存在继承关系,那么在捕获异常的时候需要注意捕获顺序。

补全下列代码,使得程序正常运行。

裁判测试程序:

public static void main(String[] args) {

Scanner sc = new Scanner(System.in);

while (sc.hasNext()) {

String choice = sc.next();

try {

if (choice.equals("number"))

throw new NumberFormatException();

else if (choice.equals("illegal")) {

throw new IllegalArgumentException();

} else if (choice.equals("except")) {

throw new Exception();

} else

break;

}

/*这里放置你的答案*/

}//end while

sc.close();

}

输出说明

在catch块中要输出两行信息:

第1行:要输出自定义信息。如下面输出样例的number format exception

第2行:使用System.out.println(e)输出异常信息,e是所产生的异常。

输入样例

number illegal except quit

输出样例

number format exception

java.lang.NumberFormatException

illegal argument exception

java.lang.IllegalArgumentException

other exception

java.lang.Exception

解析:通过测试程序可以看出结构,只需要我们写个catch即可,输出的第一行未自定义的一个提示字样,第二行为抛出的异常信息,所以只需要catch里面输出自定义信息+异常信息即可,没有什么难度。

需要注意的就是自定义信息可以从输出样例中获得,判断后输出即可;提交仅仅提交catch部分即可,全部提交会产生编译错误。

因为之前用oj提交习惯性将类名改为Main,在pta上提交正确,不知道自定义类名是否可以。

完整代码:

import java.util.*;

public class renhongjie{

public static void main(String[] args) {

Scanner sc = new Scanner(System.in);

while (sc.hasNext()) {

String choice = sc.next();

try {

if (choice.equals("number"))

throw new NumberFormatException();

else if (choice.equals("illegal")) {

throw new IllegalArgumentException();

} else if (choice.equals("except")) {

throw new Exception();

} else

break;

}

catch(Exception e){

if (choice.equals("number"))

System.out.println ("number format exception");

if (choice.equals("illegal"))

System.out.println ("illegal argument exception");

if (choice.equals("except"))

System.out.println ("other exception");

System.out.println (e);

}

/*这里放置你的答案*/

}//end while

sc.close();

}

}

需要提交的部分:

catch(Exception e){

if (choice.equals("number"))

System.out.println ("number format exception");

if (choice.equals("illegal"))

System.out.println ("illegal argument exception");

if (choice.equals("except"))

System.out.println ("other exception");

System.out.println (e);

}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值