1146 Topological Order (25 分)

1146 Topological Order (25 分)

This is a problem given in the Graduate Entrance Exam in 2018: Which of the following is NOT a topological order obtained from the given directed graph? Now you are supposed to write a program to test each of the options.
在这里插入图片描述

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (≤ 1,000), the number of vertices in the graph, and M (≤ 10,000), the number of directed edges. Then M lines follow, each gives the start and the end vertices of an edge. The vertices are numbered from 1 to N. After the graph, there is another positive integer K (≤ 100). Then K lines of query follow, each gives a permutation of all the vertices. All the numbers in a line are separated by a space.

Output Specification:

Print in a line all the indices of queries which correspond to “NOT a topological order”. The indices start from zero. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line. It is graranteed that there is at least one answer.

Sample Input:

6 8
1 2
1 3
5 2
5 4
2 3
2 6
3 4
6 4
5
1 5 2 3 6 4
5 1 2 6 3 4
5 1 2 3 6 4
5 2 1 6 3 4
1 2 3 4 5 6

Sample Output:

3 4

思路

  • 拓扑排序:每次先选取入度为0的节点,删除此节点及其边(使其所有指向节点的入度减1),如果不存在入度为0的节点,则图中有环,不存在拓扑排序
  • 邻接表存图
  • in[]表示入度
  • 如果结点的入度不为0,则该序列不为拓扑序列
#include <bits/stdc++.h>
using namespace std;

const int maxn = 1010;
int in[maxn];
int tmp_in[maxn];
vector<int> eage[maxn];
int n, m;

int main()
{
    scanf("%d%d",&n,&m);
    for(int i = 0; i < m; ++i){
        int a, b;
        scanf("%d%d",&a,&b);
        eage[a].push_back(b);
        in[b]++;
    }
    int k;
    vector<int> ans;
    scanf("%d",&k);
    for(int i = 0; i < k; ++i){
        bool flag = true;
        for(int j = 1; j <= n; ++j)
            tmp_in[j] = in[j];
        for(int j = 1; j <= n; ++j){
            int x;
            scanf("%d",&x);
            if(tmp_in[x] != 0) flag = false;
            for(int l = 0; l < eage[x].size(); ++l){
                int v = eage[x][l];
                tmp_in[v]--;
            }
        }
        if(!flag) ans.push_back(i);
    }
    for(int i = 0; i < ans.size(); ++i){
        if(i) printf(" ");
        printf("%d",ans[i]);
    }
    return 0;
}
  • 拓扑序列生成图
    在这里插入图片描述
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值