HDU - 2955 Robberies

Robberies

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 25698    Accepted Submission(s): 9482


Problem Description
The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university.


For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.


His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.
 

Input
The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj .
Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .
 

Output
For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.

Notes and Constraints
0 < T <= 100
0.0 <= P <= 1.0
0 < N <= 100
0 < Mj <= 100
0.0 <= Pj <= 1.0
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.
 

Sample Input
  
  
3 0.04 3 1 0.02 2 0.03 3 0.05 0.06 3 2 0.03 2 0.03 3 0.05 0.10 3 1 0.03 2 0.02 3 0.05
 

Sample Output
  
  
2 4 6
 

Source
 

Recommend
gaojie


题意:
求在安全的情况下最多可以得到多少财富。

思路:
把被抓概率转变成安全概率,然后定义一个以钱数为下标的一维数组,用动态规划的思想解题。概率的计算是相乘的。
最后从最大钱数开始循环,只要找到满足条件的就输出并结束循环。

代码:
#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
using namespace std;
int v[105];
double p[105];
double dp[10005];
int main(){
	int t;
	scanf("%d",&t);
	while(t--){
		double y,m;
		int n;
		
		memset(v,0,sizeof(v));
		memset(p,0,sizeof(p));
		memset(dp,0,sizeof(dp));
		
		scanf("%lf %d",&m,&n);
		m=1.0-m;
		
		int sum=0;
		for(int i=1;i<=n;i++){
			double j;
			scanf("%d %lf",&v[i],&p[i]);
			sum+=v[i];
			p[i]=1.0-p[i];
		}
		
		dp[0]=1.0;
		for(int i=1;i<=n;i++){
			for(int j=sum;j>=v[i];j--){
				dp[j]=max(dp[j],dp[j-v[i]]*p[i]);
			}
		}
		
		for(int i=sum;i>=0;i--){
			if(dp[i]>m){
				printf("%d\n",i);
				break;
			}
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值