Robberies
AYIT-2021 609暑假集训第一周下 记忆化搜索和背包
The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university.
For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.
His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.
Input
The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj .
Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .
Output
For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.
Notes and Constraints
0 < T <= 100
0.0 <= P <= 1.0
0 < N <= 100
0 < Mj <= 100
0.0 <= Pj <= 1.0
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.
Sample Input
3
0.04 3
1 0.02
2 0.03
3 0.05
0.06 3
2 0.03
2 0.03
3 0.05
0.10 3
1 0.03
2 0.02
3 0.05
Sample Output
2
4
6
题意:去偷银行,每个银行都有失败的概率,小偷有个概率上限,超过了就会被抓,问最多能偷多少钱
题型:01背包
思路:先把失败概率都变成成功概率(方便计算),注意概率是 相乘的
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int v[110];
double w[110],dp[10010];
int main()
{
int t,n,i,j,m;double p;
scanf("%d",&t);
while(t--)
{
scanf("%lf%d",&p,&n);p=1-p;
for(m=i=0;i<n;i++)
{
scanf("%d%lf",&v[i],&w[i]);
m+=v[i];w[i]=1-w[i];
}
memset(dp,0,sizeof(dp));dp[0]=1;
for(i=0;i<n;i++)
for(j=m;j>=v[i];j--)
dp[j]=max(dp[j],dp[j-v[i]]*w[i]);
for(i=m;i>=0&&dp[i]<p;i--);
printf("%d\n",i);
}
return 0;
}