HDU 1194 JAVA

Beat the Spread!

Problem Description
Superbowl Sunday is nearly here. In order to pass the time waiting for the half-time commercials and wardrobe malfunctions, the local hackers have organized a betting pool on the game. Members place their bets on the sum of the two final scores, or on the absolute difference between the two scores.

Given the winning numbers for each type of bet, can you deduce the final scores?

Input
The first line of input contains n, the number of test cases. n lines follow, each representing a test case. Each test case gives s and d, non-negative integers representing the sum and (absolute) difference between the two final scores.

Output
For each test case, output a line giving the two final scores, largest first. If there are no such scores, output a line containing “impossible”. Recall that football scores are always non-negative integers.

Sample Input
2
40 20
20 40

Sample Output
30 10
impossible

题意:给你两个数,第一个数是 X,Y之后,第二个是是X,Y差的绝对值,并且X,Y是正整数,要你求出X,Y 。如果没有符合条件的X,Y 输出impossible

package hlh;

import java.util.Scanner;

public class p1194 {
     public static void main(String[] args) {  
            Scanner sc = new Scanner(System.in);  
            int n = sc.nextInt();  
            while (n-- > 0) {  
                int s = sc.nextInt();  
                int d = sc.nextInt();  
                int temp = s - d;  
                if (temp < 0 || (temp & 0x01) == 1) {  
                    System.out.println("impossible");  
                } else {  
                    System.out.println((d + temp / 2) + " " + temp / 2);  
                }  
            }  
        }  
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值