HDU 1194 Beat the Spread! 【水题+细心】

Problem Description
Superbowl Sunday is nearly here. In order to pass the time waiting for the half-time commercials and wardrobe malfunctions, the local hackers have organized a betting pool on the game. Members place their bets on the sum of the two final scores, or on the absolute difference between the two scores.

Given the winning numbers for each type of bet, can you deduce the final scores?
 

Input
The first line of input contains n, the number of test cases. n lines follow, each representing a test case. Each test case gives s and d, non-negative integers representing the sum and (absolute) difference between the two final scores.
 

Output
For each test case, output a line giving the two final scores, largest first. If there are no such scores, output a line containing "impossible". Recall that football scores are always non-negative integers.
 

Sample Input
  
  
2 40 20 20 40
 

Sample Output
  
  
30 10 impossible


题目大意:粗心了,给定两个数字的和, 差, 要求出这两个数字是多少; 

题解:唯一考虑的点是,只有偶+偶 , 奇+奇 ,才能得到偶; 额外判断; 而且和不可能比差小; 如果得到答案后应该调换 ;

AC代码:

#include <bits/stdc++.h>
using namespace std ;
int main()
{
	int a , b , t ;
	cin>>t;
	while(t--)
	{
		cin>>a>>b;
		if(a<b)  printf("impossible\n");
		else if((a+b)%2!=0) printf("impossible\n");
		else 
		{
			int m , n ; 
			m = (a+b)/2 ;
			n = (a-b)/2 ;
			if(n>m) swap(m,n);
			printf("%d %d\n",m,n);
		}
	}
	return 0 ;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Kelisita

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值