HDU 1194 Beat the Spread!

156 篇文章 0 订阅
45 篇文章 0 订阅

/*
中文题目:打败传播
中文翻译-大意:超级xxx又来了,为了打发中场休息时间,大家就来下注最终的结果会如何。大家下注的目标为两队最终的分数和,或者两队最终分数差的绝对值。给你两个数,你能推出这两队的得分是多少吗?

Input

输入的第一列有一个整数,代表以下有多少组测试的数据。

每组测试数据为一列,有两个大于等于0的整数s和d,其中s代表比赛结束时两队分数的总和,d代表比赛结束两队分数差的绝对值。

Output

注意:美式足球的分数一定是大于等于0的整数。

当输入100    1 ,是没有两个整数相加为偶数,相减为奇数的
题目大意:求两个数,给出他们的之和和之差的绝对值,叫你就这两个数
解题思路:列两个方程求解一下即可
难点详解:看懂题意
关键点:要英语好,要看懂题意
解题人:lingnichong
解题时间:2014-08-11 20:01:16
解题体会:英语单词回去看我怎么被你的。
*/


Beat the Spread!

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4537    Accepted Submission(s): 2365


Problem Description
Superbowl Sunday is nearly here. In order to pass the time waiting for the half-time commercials and wardrobe malfunctions, the local hackers have organized a betting pool on the game. Members place their bets on the sum of the two final scores, or on the absolute difference between the two scores.

Given the winning numbers for each type of bet, can you deduce the final scores?
 

Input
The first line of input contains n, the number of test cases. n lines follow, each representing a test case. Each test case gives s and d, non-negative integers representing the sum and (absolute) difference between the two final scores.
 

Output
For each test case, output a line giving the two final scores, largest first. If there are no such scores, output a line containing "impossible". Recall that football scores are always non-negative integers.
 

Sample Input
  
  
2 40 20 20 40
 

Sample Output
  
  
30 10 impossible
 

Source
 


#include<stdio.h>
int main()
{
	int n,a,b;
	scanf("%d",&n);
	while(n--)
	{
		scanf("%d%d",&a,&b);
		if(a%2==0&&b%2!=0||a%2!=0&&b%2==0||(a<b))
			printf("impossible\n");
		else
			printf("%d %d\n",(a+b)/2,(a-b)/2);
	}
	
	return 0;
}







评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值