1077 Kuchiguse (20分)

1077 Kuchiguse (20分)
The Japanese language is notorious for its sentence ending particles. Personal preference of such particles can be considered as a reflection of the speaker’s personality. Such a preference is called “Kuchiguse” and is often exaggerated artistically in Anime and Manga. For example, the artificial sentence ending particle “nyan~” is often used as a stereotype for characters with a cat-like personality:
• Itai nyan~ (It hurts, nyan~)
• Ninjin wa iyada nyan~ (I hate carrots, nyan~)
Now given a few lines spoken by the same character, can you find her Kuchiguse?
Input Specification:
Each input file contains one test case. For each case, the first line is an integer N (2≤N≤100). Following are N file lines of 0~256 (inclusive) characters in length, each representing a character’s spoken line. The spoken lines are case sensitive.
Output Specification:
For each test case, print in one line the kuchiguse of the character, i.e., the longest common suffix of all N lines. If there is no such suffix, write nai.
Sample Input 1:
3
Itai nyan~
Ninjin wa iyadanyan~
uhhh nyan~

Sample Output 1:
nyan~

Sample Input 2:
3
Itai!
Ninjinnwaiyada T_T
T_T
必要的说明都在代码注释,还是看代码注释理解比较轻松。

#include<stdio.h>
#include<iostream>
#include<string.h>
using namespace std;

int main() {
	int N;
	scanf("%d",&N);
	char c[110][257];
	int lenmin = 257;
	getchar();
	for(int i = 0; i < N; i++) {
		cin.getline(c[i],257);
		int len = strlen(c[i]);
		if(len < lenmin) lenmin = len;
		for(int k = 0; k<len/2; k++) {
			char temp = c[i][k];//倒置,取尾音 
			c[i][k] = c[i][len-k-1];
			c[i][len-1-k] = temp;
		}
	}//一维的检测,,只需要提取第一行,然后之后每行每个检测即可
	int flag = 0;
	int ans = 0;
	for(int i = 0; i<lenmin; i++) {
		//取最短的长度
		char f = c[0][i];
		for(int j = 1; j < N; j++) {
			if(f != c[j][i]) {
				flag = 1;
				break;//下面几行都不用测了
			}
		}
		if(flag) break;  //for停止   //右边的数也不用测了
		else ans++;//如果  第一行的某一个都与下面众行都相同,记录一个ans 
	}
	if(ans)
		for(int i = ans-1; i >= 0; i--) {
			printf("%c",c[0][i]);
		}
	else
		printf("nai");
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值