PAT 1077 Kuchiguse (20 分)

1077 Kuchiguse (20 分)

The Japanese language is notorious for its sentence ending particles. Personal preference of such particles can be considered as a reflection of the speaker’s personality. Such a preference is called “Kuchiguse” and is often exaggerated artistically in Anime and Manga. For example, the artificial sentence ending particle “nyan~” is often used as a stereotype for characters with a cat-like personality:
Itai nyan~ (It hurts, nyan~)
Ninjin wa iyada nyan~ (I hate carrots, nyan~)


Now given a few lines spoken by the same character, can you find her Kuchiguse?


Input Specification:
Each input file contains one test case. For each case, the first line is an integer N (2≤N≤100). Following are N file lines of 0~256 (inclusive) characters in length, each representing a character’s spoken line. The spoken lines are case sensitive.


Output Specification:
For each test case, print in one line the kuchiguse of the character, i.e., the longest common suffix of all N lines. If there is no such suffix, write nai.

Sample Input 1:

3
Itai nyan~
Ninjin wa iyadanyan~
uhhh nyan~

Sample Output 1:

nyan~

Sample Input 2:

3
Itai!
Ninjinnwaiyada T_T
T_T

Sample Output 2:

nai




解析

题意是寻找一组字符串中最大相同后缀,并输出。如果没有:则输出‘nai’
最大相同后缀:完全可以使用reverse_iterator反向迭代器。这样思路就类似寻找最大相同前缀。
最后一个测试点是

2
qaq
qaq

看看你的程序能不能处理咯



Code:

#include<string>
#include<vector>
#include<iostream>
#include<utility>
using namespace std;
const string out = "nai";
int main()
{
	int N;
	cin >> N;
	getchar();
	vector<string> spoken(N);
	vector<string::reverse_iterator> it(N);
	string result;
	for (int i = 0; i < N; i++) {
		getline(cin,spoken[i]);
		it[i] = spoken[i].rbegin();
	}
	bool Continue = true;
	while (Continue) {
		auto first = it[0];
		for (int i = 0; i < N && Continue; i++) {
			if (it[i] == spoken[i].rend() || *first != *it[i]) {  //到尾巴了  或 不是最大后缀
				Continue = false;
				break;
			}
			it[i]++;
		}
		if(Continue)
			result = *first + result;
	}
	if (result.empty())
		cout << out;
	else
		cout << result;
}

Pure C:

#include <stdio.h>
#include <string.h>
#include <iostream>
struct string {
	char a[1000];
	int len;
}input[200];
int findsuffix(char *suffix,int N){
	int walk = 0, suffix_size = 0;
	while (true) {
		for (int i = 1; i < N; i++) {
			int len1 = input[i - 1].len, len2 = input[i].len;
			if ((len1 - walk - 1 < 0 || len2 - walk - 1 < 0) ||
				(input[i - 1].a[len1 - walk - 1] != input[i].a[len2 - walk - 1])) {
				suffix[suffix_size] = '\0';
				return suffix_size;
			}
		}
		suffix[suffix_size++] = input[0].a[input[0].len - walk - 1];
		walk++;
	}
}
int main()
{
	int N;
	scanf("%d", &N);
	getchar();
	for (int i = 0; i < N; i++) {
		std::cin.getline(input[i].a,1000);
		input[i].len = strlen(input[i].a);
	}
	char suffix[1000];
	int len = findsuffix(suffix, N);
	if (len == 0)
		printf("nai");
	for(int i=0;i<len;i++)
		printf("%c", suffix[len-i-1]);
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值