HDU 1540 Tunnel Warfare (线段树,区间合并)


Tunnel Warfare

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9270    Accepted Submission(s): 3609


Problem Description
During the War of Resistance Against Japan, tunnel warfare was carried out extensively in the vast areas of north China Plain. Generally speaking, villages connected by tunnels lay in a line. Except the two at the ends, every village was directly connected with two neighboring ones.

Frequently the invaders launched attack on some of the villages and destroyed the parts of tunnels in them. The Eighth Route Army commanders requested the latest connection state of the tunnels and villages. If some villages are severely isolated, restoration of connection must be done immediately!
 

Input
The first line of the input contains two positive integers n and m (n, m ≤ 50,000) indicating the number of villages and events. Each of the next m lines describes an event.

There are three different events described in different format shown below:

D x: The x-th village was destroyed.

Q x: The Army commands requested the number of villages that x-th village was directly or indirectly connected with including itself.

R: The village destroyed last was rebuilt.
 

Output
Output the answer to each of the Army commanders’ request in order on a separate line.
 

Sample Input
      
      
7 9 D 3 D 6 D 5 Q 4 Q 5 R Q 4 R Q 4
 

Sample Output
      
      
1 0 2 4

题意:D表示摧毁某个村庄,R表示修复最后一个被摧毁的村庄,Q表示询问包含x在内的最大连续区间

思路:利用线段树求最大连续区间,我最近刚学线段树,这种题目对我来说还是有难度的,参考了别人的博客,才理解

上代码

#include<iostream>
#include<cmath>
#include<cstring>
#include<cstdio>
#include<string>
#include<queue>
#include<stack>
#include<vector>
#include<map>
#include<algorithm>
using namespace std;
#define ll long long
#define inf 0x3f3f3f3f
#define ls l,m,rt<<1
#define rs m+1,r,rt<<1|1
#define maxn 50010
int len, R, L;
struct node
{
	int llen, rlen;//左右最大连续区间
}tree[maxn << 2];
void build(int l, int r, int rt)
{
	tree[rt].llen = tree[rt].rlen = r - l + 1;//一开始左右最大连续区间都是满的
	if (l == r)
		return;
	int m = (l + r) / 2;
	build(ls);
	build(rs);
}
void updata(int l, int r, int rt, int id, int a)
{
	if (l == r)
	{
		tree[rt].llen = tree[rt].rlen = a;//摧毁或者回复
		return;
	}
	int m = (l + r) / 2;
	if (id <= m)
		updata(ls, id, a);
	else
		updata(rs, id, a);
	//以下是代码的核心
	//父区间的最大左右区间
	tree[rt].llen = tree[rt << 1].llen;
	tree[rt].rlen = tree[rt << 1 | 1].rlen;
	if (tree[rt].llen == m - l + 1)//如果左子树区间满了,父左区间要加上右子树的左区间
		tree[rt].llen += tree[rt << 1 | 1].llen;
	if (tree[rt].rlen == r - m)//如果右子树右区间满了,父右区间要加上左子树的右区间
		tree[rt].rlen += tree[rt << 1].rlen;
}
//查询的话,就从那个数开始,看能不能和自己左(右)区间的合并
void query(int l, int r, int rt, int id)
{
	if (l == r)
	{
		if (tree[rt].llen)
			R = L = 1;
		else
			R = L = 0;
		len = tree[rt].llen;
		return;
	}
	int m = (l + r) / 2;
	//左区间满向右,右区间满向左
	if (id <= m)
	{
		query(ls, id);
		if (L)
			len += tree[rt << 1 | 1].llen;//能和右区间的合并
		if (tree[rt << 1 | 1].llen<r - m)//父区间不满,不能再和右区间合并了
			L = 0;
	}
	else
	{
		query(rs, id);
		if (R)
			len += tree[rt << 1].rlen;//能和左区间合并
		if (tree[rt << 1].rlen<m - l + 1)//父区间不满,不能再和左区间合并了
			R = 0;
	}
}
int main()
{
	//freopen("Text.txt", "r", stdin);
	int n, m, s[maxn], sn, id;
	char ch[2];
	while (scanf("%d%d", &n, &m) != EOF)
	{
		build(1, n, 1);
		sn = 0;
		while (m--)
		{
			scanf("%s", ch);
			if (ch[0] == 'D')
			{
				scanf("%d", &id);
				s[++sn] = id;
				updata(1, n, 1, id, 0);
			}
			else if (ch[0] == 'R')
			{
				if (sn)
					updata(1, n, 1, s[sn], 1), sn--;//修复最后一个被破坏的村庄
			}
			else
			{
				scanf("%d", &id);
				query(1, n, 1, id);
				printf("%d\n", len);
			}
		}
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
提供的源码资源涵盖了Java应用等多个领域,每个领域都包含了丰富的实例和项目。这些源码都是基于各自平台的最新技术和标准编写,确保了在对应环境下能够无缝运行。同时,源码中配备了详细的注释和文档,帮助用户快速理解代码结构和实现逻辑。 适用人群: 适合毕业设计、课程设计作业。这些源码资源特别适合大学生群体。无论你是计算机相关专业的学生,还是对其他领域编程感兴趣的学生,这些资源都能为你提供宝贵的学习和实践机会。通过学习和运行这些源码,你可以掌握各平台开发的基础知识,提升编程能力和项目实战经验。 使用场景及目标: 在学习阶段,你可以利用这些源码资源进行课程实践、课外项目或毕业设计。通过分析和运行源码,你将深入了解各平台开发的技术细节和最佳实践,逐步培养起自己的项目开发和问题解决能力。此外,在求职或创业过程中,具备跨平台开发能力的大学生将更具竞争力。 其他说明: 为了确保源码资源的可运行性和易用性,特别注意了以下几点:首先,每份源码都提供了详细的运行环境和依赖说明,确保用户能够轻松搭建起开发环境;其次,源码中的注释和文档都非常完善,方便用户快速上手和理解代码;最后,我会定期更新这些源码资源,以适应各平台技术的最新发展和市场需求。 所有源码均经过严格测试,可以直接运行,可以放心下载使用。有任何使用问题欢迎随时与博主沟通,第一时间进行解答!

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值