POJ 2470 Relatives (欧拉函数)

Relatives
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 15269 Accepted: 7731

Description

Given n, a positive integer, how many positive integers less than n are relatively prime to n? Two integers a and b are relatively prime if there are no integers x > 1, y > 0, z > 0 such that a = xy and b = xz.

Input

There are several test cases. For each test case, standard input contains a line with n <= 1,000,000,000. A line containing 0 follows the last case.

Output

For each test case there should be single line of output answering the question posed above.

Sample Input

7
12
0

Sample Output

6
4

Source


大意:求n以内与n互质的数的个数

思路:若p为x的素因子,则欧拉函数值φ(x)=x(1-1/p1)(1-1/p2)(1-1/p3)(1-1/p4)…..(1-1/pn)

上代码:

#include<iostream>
#include<string>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<cstdio>
#include<queue>
#include<stack>
#include<vector>
using namespace std;
#define ll long long
#define inf 0x3f3f3f3f
#define llinf 0x3f3f3f3f3f3f3f3f
#define mod (int)1e9+7
#define max 1e5+10
//直接实现法
int eular(int n)
{
	int res=n;
	for(int i=2;i*i<=n;i++)
	{
		if(n%i==0)//寻找质因子,不是互质的数,且找到的第一个必定为素数
		{
			res=res/i*(i-1);
			while(n%i==0)//把该素因子全部约掉,就是说i再也不是n的因子了
				n/=i;
		}
	}
	if(n>1)//若最后一个大于1,说明这个也是他的质因子
		return res=res/n*(n-1);
	return res;
}
int main()
{
	int n;
	while(scanf("%d",&n)&&n)
	{
		printf("%d\n",eular(n));
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值