7-7 输出GPLT(20 分)

7-7 输出GPLT(20 分)
给定一个长度不超过10000的、仅由英文字母构成的字符串。请将字符重新调整顺序,按GPLTGPLT….这样的顺序输出,并忽略其它字符。当然,四种字符(不区分大小写)的个数不一定是一样多的,若某种字符已经输出完,则余下的字符仍按GPLT的顺序打印,直到所有字符都被输出。

输入格式:
输入在一行中给出一个长度不超过10000的、仅由英文字母构成的非空字符串。

输出格式:
在一行中按题目要求输出排序后的字符串。题目保证输出非空。

输入样例:
pcTclnGloRgLrtLhgljkLhGFauPewSKgt
输出样例:
GPLTGPLTGLTGLGLL

这道题思路简单,下面给出C与Java版代码,仅供参考

import java.util.ArrayList;
import java.util.Scanner;
public class Main {
    public static void main(String[] args){
    Scanner sc = new Scanner(System.in);
    String str=sc.nextLine(),t;
    sc.close();
    ArrayList<Character> Glist=new ArrayList<>();
    ArrayList<Character> Plist=new ArrayList<>();
    ArrayList<Character> Llist=new ArrayList<>();
    ArrayList<Character> Tlist=new ArrayList<>();
    t=str.toUpperCase();
    System.out.println(t);
    for(int i=0;i<t.length();i++){
        if(t.charAt(i)=='G' ){
            Glist.add(t.charAt(i));
        }
        if((t.charAt(i)=='P')){
            Plist.add(t.charAt(i));
        }
        if((t.charAt(i)=='L')){
            Llist.add(t.charAt(i));
        }
        if((t.charAt(i)=='T')){
            Tlist.add(t.charAt(i));
        }
    }
        int maxSize=Glist.size();
        if (Plist.size() > maxSize) {
            maxSize = Plist.size();
        }
        if (Llist.size() > maxSize) {
            maxSize = Llist.size();
        }
        if (Tlist.size() > maxSize) {
            maxSize = Tlist.size();
        }
        for(int i=0;i<maxSize;i++){
            if(i<Glist.size()){
                System.out.print(Glist.get(i));
            }
            if(i<Plist.size()){
                System.out.print(Plist.get(i));
            }
            if(i<Llist.size()){
                System.out.print(Llist.get(i));
            }
            if(i<Tlist.size()){
                System.out.print(Tlist.get(i));
            }
        }

}
}
#include <stdio.h>  
#include <stdlib.h>  

/* run this program using the console pauser or add your own getch, system("pause") or input loop */  

int main(int argc, char *argv[]) {  
    char cur;  
    int num,g=0,p=0,l=0,t=0;  
    while(scanf("%c",&cur)&&cur!='\n'){  
        if(cur=='G'||cur=='g'){  
            g++;  
        }  
        if(cur=='P'||cur=='p'){  
            p++;  
        }  
        if(cur=='L'||cur=='l'){  
            l++;  
        }  
        if(cur=='T'||cur=='t'){  
            t++;  
        }  
    }  
    while(g>0||p>0||l>0||t>0){  
        if(g>0){  
            printf("G");  
            g--;  
        }  
        if(p>0){  
            printf("P");  
            p--;  
        }  
        if(l>0){  
            printf("L");  
            l--;  
        }  
        if(t>0){  
            printf("T");  
            t--;  
        }  
    }  
    return 0;  
}  

  • 3
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值