递归例题

1664:Placing apples
http://bailian.openjudge.cn/practice/1664/
递归求解问题的经典分解
总Time Limit:1000msMemory Limit:65536kB
Description
We are going to place M same apples into N same plates.
There could be some empty plates.
How many methods do we have?
When we have 7 applesand 3 plates, the methods, (1, 5, 1) and (5, 1, 1) are the same.
Input
The first line is the number of test cases, t. 0<=t<=20
The next t lines are test cases containing two numbers, M and N. 1<=M, N<=10.
Output
Output the numbers of method in each test case in one line.
Sample Input
1
7 3

Sample Output
8
找到递归的子问题
首先 将问题分解为 m < n和m>n的情况,即有没有空盘子
当m < n 肯定至少有n-m个空盘子, f(m,n) = f(m,m);
当m > n, 可以将问题分解为有空盘子, 和没有空盘子
f(m,n) = f(m,n-1) + f(m-n,n);
f(m,n-1) 是指至少有一个空盘子的情况,
f(m-n, n) 是指先在所有的盘子里面都放一个苹果, 这样就没有空盘子了
所以代码如下

#include<iostream>
using namespace std;
int f(int m,int n){
    if(m == 0)
        return 1;//判断递归停止的条件,当没有苹果的时候, 这个时候不放苹果就是一种方法
    if(n == 0)
        return 0;//当没有盘子的时候, f(m,0) 肯定是零
    if(m < n)
        return f(m,m);

        return f(m,n-1) + f(m-n,n);

}int main(void){
  int N;
  cin>>N;
  while(N--)
  {
      int m,n;
      cin>>m>>n;
      cout<<f(m,n)<<endl;
  }

  return 0;}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值