解决Ubuntu内核更新或安装软件时出现的问题:下列软件包有未满足的依赖关系 : linux-generic依赖: linux-headers-generic (= 4.15.0.65.67)

问题如下:
在这里插入图片描述
之前在网上查到的输入sudo apt-get update --fix-missing等命令或直接删除多余内核并不能解决此类软件包损坏问题,运行这些命令后还会出现未满足依赖关系的错误

解决方案:
命令行输入sudo apt --fix-broken install
在这里插入图片描述中途执行时选择Y,直接解决。
由于Linux升级后,内核版本太多会导致空间不足,为保证不再出错,可使用dpkg --get-selections | grep linux-image查看内核安装情况并使用sudo apt-get purge linux-image-4.15.0-62-generic等命令卸载版本比较老的内核,保留1-2个内核即可 。

  • 2
    点赞
  • 11
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 3
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Gabriel.Tian

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值