PAT(Advanced)甲级---1103 Integer Factorization (30分)【DFS】

The K−P factorization of a positive integer N is to write N as the sum of the P-th power of K positive integers. You are supposed to write a program to find the K−P factorization of N for any positive integers N, K and P.

Input Specification:

Each input file contains one test case which gives in a line the three positive integers N (≤400), K (≤N) and P (1<P≤7). The numbers in a line are separated by a space.

Output Specification:

For each case, if the solution exists, output in the format:

N = n[1]^P + … n[K]^P
where n[i] (i = 1, …, K) is the i-th factor. All the factors must be printed in non-increasing order.

Note: the solution may not be unique. For example, the 5-2 factorization of 169 has 9 solutions, such as 122+4​2+22​+22+12, or 112+62+22+22+22​​ , or more. You must output the one with the maximum sum of the factors. If there is a tie, the largest factor sequence must be chosen – sequence { a1 ,a2​​ ,⋯,aK​ } is said to be larger than { b​1,b2,⋯,b​K } if there exists 1≤L≤K such that ai​​ =bifor i<L and aL>bL.
If there is no solution, simple output Impossible.

Sample Input 1:

169 5 2

Sample Output 1:

169 = 6^2 + 6^2 + 6^2 + 6^2 + 5^2

Sample Input 2:

169 167 3

Sample Output 2:

Impossible

题目大意

给三个正整数N、K、P,将N表示成K个正整数(可以相同,递减排列)的P次方和,如果有多种方案,选择底数n1+…+nk最大的方案,如果还有多种方案,选择底数序列的字典序最大的方案。

#include<cstdio>
#include<vector>
#include<cmath>
using namespace std;

int N, K, P;
vector<int> ansfac,tempfac; //存储所有因子
int maxsum = -1;//最大因子总和

void dfs(int nowf,int nowK, int sum, int Psum){ //当前的因子,当前因子个数,片段和,P总和
	if (nowK == K){
		if (Psum == N&&sum > maxsum){
			maxsum = sum;
			ansfac = tempfac;
		}
		return;
	}
	if (Psum >= N || nowf < 1)return;
	tempfac.push_back(nowf);
	dfs(nowf, nowK + 1, sum + nowf, Psum + pow(nowf, P)); //要当前因子
	tempfac.pop_back();
	dfs(nowf - 1, nowK, sum, Psum); //不要当前因子
}

int main(){
	scanf("%d%d%d", &N, &K, &P);
	int maxf = sqrt(N*1.0);
	dfs(maxf,0, 0, 0);
	if (ansfac.empty())printf("Impossible\n");
	else { 
		printf("%d = ", N);
		for (auto it = ansfac.begin(); it != ansfac.end(); it++){
			if (it != ansfac.begin())printf(" + ");
			printf("%d^%d", *it, P);
		}
		printf("\n");
	}
}
总结
  • DFS会遍历所有的可能性,所以在有原始序列的情况下,选择满足条件并且最优的自序列的题,用DFS。
  • 一般首先需要自行的筛选到原始序列,然后DFS得到最优的序列。这道题得到最大因子然后dfs依次递减就可以得到原始序列
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值