Maximum Subsequence Sum(java)

7-1 Maximum Subsequence Sum(25 分)

Given a sequence of K integers { N​1​​, N​2​​, ..., NK​​ }. A continuous subsequence is defined to be { Ni​​, Ni+1​​, ..., Nj​​ } where 1≤ijK. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

 

 

思路:

1、在线处理,就是每输入一个数据就进行即时处理,实时获得当前最优解。

2、题目是输出最大子序列的第一个数字和最后一个数字,不是下标,注意审题。

import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
import java.io.StreamTokenizer;

public class Main {
	static int n;

	public static void main(String[] args) throws Exception {
		// TODO Auto-generated method stub
		StreamTokenizer in = new StreamTokenizer(new BufferedReader(
				new InputStreamReader(System.in)));

		in.nextToken();
		int n = (int) in.nval;
		int[] num = new int[n];
		for (int i = 0; i < n; i++) {
			in.nextToken();
			num[i] = (int) in.nval;
		}

		int start = -1, end = 0, sum = -1;
		int s = -1, e = 0, temp = 0;
		int index = 0;
		while (index < n) {
			if (num[index] >= 0) {
				temp = temp + num[index];
				e = index;
				if (s == -1)
					s = index;
				if (temp > sum) {
					sum = temp;
					start = s;
					end = e;
				}
			} else {
				temp = temp + num[index];
				if (temp < 0) {
					temp = 0;
					s = -1;
				} else {
					e = index;
				}
			}
			index++;

		}
		if (sum < 0 && n > 0) {
			System.out.print("0" + " " + num[0] + " " + num[n - 1]);
		} else if (sum >= 0)
			System.out.print(sum + " " + num[start] + " " + num[end]);
		else
			System.out.print(0);
	}

}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值