java实现Maximum Subsequence Sum

题目

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (<= 10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

思路

这个题需要注意三种情况:

  1. 如果输入的元素全为负数,则最大和为0,同时输出首尾的负数。
  2. 如果输入的元素为负数和0,应该输出0的下标
  3. 输出的首尾元素应该具有最小下标。

代码

public class MaximumSubsequenceSum {
	static boolean allMinus = false;//默认不全是负数
	static int start;	//最后输出首坐标
	static int end;		//最后输出尾坐标
	public static int subsquenceSum(int a[]) {
		int maxSum = -1;	//最大和,已检查全是负数和0跟复数的情况
		int thisSum = 0;	//当前和
		for (int i = 0; i < a.length; i++) {	//从左往右找最大子序列和
			thisSum += a[i];
			if (thisSum > maxSum) {	//大于时候赋值给maxSum
				maxSum = thisSum;
				end = i;	//获取尾坐标
			}
			if (thisSum < 0) {	//当前和小于0,舍去这一段,重新开始
				thisSum = 0;
			}
		}
		thisSum = 0;
		for (int i = end; i >= 0; i--) {	//从右往左找最大和,以及开始坐标
			thisSum += a[i];
			if (thisSum == maxSum) {
				start = i;
			}
		}
		if (maxSum <= 0) {	//全是负数的情况
			maxSum = 0;
			allMinus = true;
			start = 0;
			end = a.length - 1;
		}
		return maxSum;
	}
	
	
	public static void main(String[] args) {
		System.out.println("开始输入:");
		Scanner sc = new Scanner(System.in);
		int N = sc.nextInt();
        int a[] = new int[N];
        for (int i = 0; i < N; i++) {
            a[i] = sc.nextInt();
        }
        if (allMinus) {//全是负数
            System.out.println(0 + " " + a[0] + " " + a[N - 1]);
        } else {//不全是负数
            System.out.println(subsquenceSum(a) + " " + start + " " + end);
        }
	}
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值