线性结构1 Maximum Subsequence Sum(Java)

题目

Given a sequence of K integers { N​1​​, N​2​​, …, N​K​​ }. A continuous subsequence is defined to be { N​i​​, N​i+1​​, …, N​j​​ } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.
Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:
10
-10 1 2 3 4 -5 -23 3 7 -21
Sample Output:
10 1 4

解答

用的是Java来写的

import java.io.*;

public class MaximumSubsequenceSum {

	public static void main(String[] args) throws IOException {
		int[] myList = getList();
		int[] answer = getAnswer(myList);
		System.out.print(answer[0] + " " + answer[1] + " " + answer[2]);
	}

	static int[] getList() throws IOException { // 获取输入的数组 输入格式为第一行数组大小 第二行为空格隔开的数组内容
		BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
		int arrLength = 0;
		String arrStr = null;
		try {
			arrLength = Integer.parseInt(br.readLine());
			arrStr = br.readLine();
		} catch (Exception e) {
			System.out.print(e.toString());
		}
		int[] myList = new int[arrLength];
		String[] arrSplit = arrStr.split(" ");
		for (int i = 0; i < arrLength; i++) {
			myList[i] = Integer.parseInt(arrSplit[i]);
		}
		return myList;
	}

	static int[] getAnswer(int[] myList) { // 以数组形式返回答案 分别为最大子列和、该子列首位数、该子列末位数
		// 使用在线处理的算法,从左往右依次相加,将最大值保存下来。如果当前的和为负数,则不会使后续序列的和更大,因此抛弃,从0开始重新相加。
		int maxSum = -1; // 暫存的最大子列和
		int nowSum = 0; // 当前的子列和,当其为负数时清零
		int a = 0; // 最大子列和的首项位置
		int b = myList.length - 1;// 最大子列和的末项位置

		for (int i = 0; i < myList.length; i++) {
			nowSum += myList[i];
			if (nowSum > maxSum) {
				maxSum = nowSum;
				b = i; // 得到最大值的末项位置
			}
			if (nowSum < 0) {
				nowSum = 0;
				if(i == myList.length - 1 && maxSum == -1)
					maxSum = 0;
			}
		}
		nowSum = 0;
		for (int i = b; i >= 0; i--) { // 由末项位置倒推得出首项位置
			nowSum += myList[i];
			if (nowSum == maxSum) {
				a = i;
			}
		}
		int[] answer = { maxSum, myList[a], myList[b] };
		return answer;
	}
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值