Insert or Merge(java)

7-13 Insert or Merge(25 分)

According to Wikipedia:

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.

Merge sort works as follows: Divide the unsorted list into N sublists, each containing 1 element (a list of 1 element is considered sorted). Then repeatedly merge two adjacent sublists to produce new sorted sublists until there is only 1 sublist remaining.

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in the first line either "Insertion Sort" or "Merge Sort" to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resuling sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0

Sample Output 1:

Insertion Sort
1 2 3 5 7 8 9 4 6 0

Sample Input 2:

10
3 1 2 8 7 5 9 4 0 6
1 3 2 8 5 7 4 9 0 6

Sample Output 2:

Merge Sort
1 2 3 8 4 5 7 9 0 6

思路:

1、是否是插入排序很好判断,前面是有序的,从不有序的那个点开始,后面的元素和初始序列一样。

2、在进行插入排序时,注意应该从前往后判断从哪个点开始不有序的,就从那个点开始排。保证你排完之后,确实有点发生了移动。

 

import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
import java.io.StreamTokenizer;

public class Main {

	public static void main(String[] args) throws IOException {
		// TODO Auto-generated method stub
		StreamTokenizer in = new StreamTokenizer(
				new BufferedReader(new InputStreamReader(System.in)));
		in.nextToken();
		int n = (int) in.nval;
		int a []  = new int[n];
		int b []  = new int [n];
		for(int i =0;i<n;i++) {
			in.nextToken();
			a[i] = (int) in.nval;
		}
		for(int i = 0;i<n;i++) {
			in.nextToken();
			b[i] = (int) in.nval;
		}
		
		boolean bool = judge(a,b,n);
		if(bool) {
			System.out.println("Insertion Sort");
			insert_sort(a,b,n);
		}
		else {
			System.out.println("Merge Sort");
			merge_sort(a,b,n);
		}
		
	}

	private static void merge_sort(int[] a, int[] b, int n) {
		// TODO Auto-generated method stub
		int i;
		int temp [] = new int[n];
		int length=1;
		while(length<n) {
			merge_pass(a,temp,length,n);
			for(i=0;i<n;i++) {
				if(temp[i]!=b[i])
					break;
			}
			if(i==n)
				break;
			
			length*=2;
			
			for(i=0;i<n;i++) {
				temp[i] = a[i];
			}
		}
		length*=2;
		merge_pass(a,temp,length,n);
		
		int flag=0;
		for(i=0;i<n;i++) {
			if(flag!=0)
				System.out.print(" ");
			System.out.print(temp[i]);
			flag =1;
		}
		
	}
	private static void merge_pass(int[] a, int temp[],int length, int n) {
		int i;
		// TODO Auto-generated method stub
		for( i =0;i<=n-2*length;i+=2*length) {
			merge(a,temp,i,i+length,i+2*length-1);
		}
		
		if(n-i>length)
			merge(a,temp,i,i+length,n-1);
		else
			for(int k =i;k<n;k++) {
				temp[k] =a[k];
			}
		
		
	}


	private static void merge(int[] a, int[] temp, int L, int R, int right_end) {
		// TODO Auto-generated method stub
		int left_end =R-1;
		int k =L ;
		int num = right_end-L+1;
		while(L<=left_end&&R<=right_end) {
			if(a[L]<=a[R]) {
				temp[k] = a[L];
				k++;L++;
			}
			else {
				temp[k] = a[R];
				k++;R++;
			}
		}
		
		while(L<=left_end) {
			temp[k] =a[L];
			k++;
			L++;
		}
		
		while(R<=right_end) {
			temp[k] =a[R];
			k++;
			R++;
		}
		
		for(int i =k-1,j =0 ;j<num;j++,i--) {
			a[i] = temp[i];
		}
	}
	private static void insert_sort(int[] a, int[] b, int n) {
		// TODO Auto-generated method stub
		int i,j=0;
		for(i =0;i<n&&b[i]<=b[i+1];i++) {
			;
		}
	
		
		int tmp =a[i+1];
		int flag=0;
		
		for(j =i;j>=0&&b[j]>tmp;j--) {
			b[j+1]=b[j];
			flag=1;
		}
		b[j+1] = tmp;
	
		
		flag=0;
		for(i=0;i<n;i++) {
			if(flag!=0)
				System.out.print(" ");
			System.out.print(b[i]);
			flag =1;
		}
		
	}

	private static boolean judge(int[] a,int[] b, int n) {
		int i;
		// TODO Auto-generated method stub
		for(i = 0;b[i]<=b[i+1]&&i<n-1;i++) {
			;
		}
		
		int flag =0;
		while(flag==0&&i<n-1) {
			if(a[i+1]!=b[i+1]) {
				flag =1;
			}
			i++;
		}
		
		if(flag ==0)
			return true;
		else
			return false;
	}

}

 

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
引用中提到了一种用迭代的方法进行归并排序的实现方式。在这种方法中,我们从初始有序长度为1开始,不断对已经有序的左组和未经排序的右组进行合并,同时左右组的长度会一起增长,直到完成排序。具体的实现代码如下: ```java public static void mergeSort2(int[] arr){ if(arr == null || arr.length < 2){ return; } int N = arr.length; int mergeSize = 1; while(mergeSize < N){ int L = 0; while(L < N){ int M = L + mergeSize - 1; if (M >= N){ break; } int R = Math.min(M + mergeSize, N - 1); merge(arr, L, M, R); L = R + 1; } if (mergeSize > N / 2){ break; } mergeSize <<= 1; } } private static void merge(int[] arr, int L, int M, int R){ // 合并操作 // ... } ``` 这段代码实现了归并排序的核心逻辑。其中,mergeSort2方法用来调用merge方法进行归并操作,而merge方法则完成了具体的合并操作。在merge方法中,我们可以根据实际需求来实现对两个有序数组的合并操作。<span class="em">1</span><span class="em">2</span><span class="em">3</span> #### 引用[.reference_title] - *1* [Merge.java](https://download.csdn.net/download/weixin_44437775/12561524)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_1"}}] [.reference_item style="max-width: 33.333333333333336%"] - *2* [Java HashMap merge() 方法](https://blog.csdn.net/weixin_34247778/article/details/114561268)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_1"}}] [.reference_item style="max-width: 33.333333333333336%"] - *3* [归并排序(MergeSort) Java实现及解析](https://blog.csdn.net/HLComet_Bay_WC/article/details/120661543)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_1"}}] [.reference_item style="max-width: 33.333333333333336%"] [ .reference_list ]

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值