Hashing (java)

7-17 Hashing(25 分)

The task of this problem is simple: insert a sequence of distinct positive integers into a hash table, and output the positions of the input numbers. The hash function is defined to be H(key)=key%TSize where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.

Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive numbers: MSize (≤10​4​​) and N (≤MSize) which are the user-defined table size and the number of input numbers, respectively. Then N distinct positive integers are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the corresponding positions (index starts from 0) of the input numbers in one line. All the numbers in a line are separated by a space, and there must be no extra space at the end of the line. In case it is impossible to insert the number, print "-" instead.

Sample Input:

4 4
10 6 4 15

Sample Output:

0 1 4 -

思路:

1、有几个容易犯错的点。1不是素数也不是合数,2是素数。写next_prime()函数时加健壮性判断,另外就是用户给的可能就是一个素数。判断时可以首先判断i是不是偶数,这里只判断奇数就行,可以节约很多时间。

2、 犯了一个非常傻的错误,就是pos加1.....n的平方的时候不是累加。是pos加1的平方判断对不对,再pos加2的平方对不对。而不是加了1的平方,然后在此基础上加2的平方,很傻很天真。

import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
import java.io.StreamTokenizer;

public class Main {

	public static void main(String[] args) throws IOException {
		// TODO Auto-generated method stub
		StreamTokenizer in  = new StreamTokenizer(new BufferedReader(new InputStreamReader(System.in)));
		in.nextToken();
		int M = (int) in.nval;
		
		in.nextToken();
		int N = (int) in.nval;
		
		int tablesize = next_prime(M);
		int [] H = new int[tablesize];
		
		
		int flag =1;
		for(int i =0;i<N;i++) {
			in.nextToken();
			int num = (int) in.nval;
			int pos = num%tablesize;
			int q =1;
			while(H[pos]!=0) {
				pos = pos -(int) Math.pow(q-1, 2);
				pos = (int) (pos+Math.pow(q, 2));
				q=q+1;
				pos = pos%tablesize;
				if(q>tablesize)
					break;
			}
			if(q<=tablesize)
				H[pos] = num;
			
			if(flag !=1)
				System.out.print(" ");
			flag=0;
			if(q>tablesize)
				System.out.print("-");
			else
				System.out.print(pos);
		}
	}

	private static int next_prime(int m) {
		// TODO Auto-generated method stub
		if(m==1)
			return 2;
		for(int i = m;;i++) {
			int flag =0;
			if(i%2==0)
				continue;
			for(int j =2;j<=Math.sqrt(i);j++){
				if(i%j==0) {
					flag =1;
					break;
				}
			}
			if(flag==0) {
				return i;
			}
		}
	}

}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值