Spell It Rirht (Stack的使用)

1005 Spell It Right (20 分)

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification:

Each input file contains one test case. Each case occupies one line which contains an N (≤10​100​​).

Output Specification:

For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input:

12345

Sample Output:

one five

思路:

1、输入的数字最大到10^100,显然超出了Int和Long的范围,在java中可以使用大整数BigInteger这个类,

可以存储的范围:-2eInteger.MAX_VALUE (exclusive) to +2eInteger.MAX_VALUE (exclusive).

2、也可以把读入的当作一个字符串,即in.next(),然后转化为字符数组,再逐一变为int求和。

3、从一个整型的最高位开始读,要使用栈 Stack,先把低位压进去,就可以先取出高位。

import java.math.BigInteger;
import java.util.Scanner;
import java.util.Stack;

public class Main {
	static int flag=0;
	public static void main(String[] args) {
		// TODO Auto-generated method stub
		Scanner in = new Scanner (System.in);
		BigInteger n = in.nextBigInteger();
		int sum = 0;
		while(n.compareTo(BigInteger.valueOf(0))>0) {
			sum+=n.mod(BigInteger.valueOf(10)).intValue();
			n = n.divide(BigInteger.valueOf(10));
		}
		
		Stack<Integer> st = new Stack<>();
		if(sum==0)
			st.push(0);
		
		while(sum!=0) {
			st.push(sum%10);
			sum = sum/10;
		}
		
		
		
		while(!st.isEmpty()) {
			switch (st.pop()) {
			case 0 :sop("zero");break;
			case 1 :sop("one");break;
			case 2 :sop("two");break;
			case 3 :sop("three");break;
			case 4 :sop("four");break;
			case 5 :sop("five");break;
			case 6 :sop("six");break;
			case 7 :sop("seven");break;
			case 8 :sop("eight");break;
			case 9 :sop("nine");break;
			
			}
		}
	}

	private static void sop(String string) {
		// TODO Auto-generated method stub
		if(flag == 0) {
			System.out.print(string);
			flag =1;
		}
		else 
			System.out.print(" "+string);	
	}
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值