Til the Cows Come Home(poj 2387 Dijkstra算法)

Description

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible. 

Farmer John's field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it. 

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.

Input

* Line 1: Two integers: T and N 

* Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.

Output

* Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.

Sample Input

5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100

Sample Output

90

Hint

INPUT DETAILS: 

There are five landmarks. 

OUTPUT DETAILS: 

Bessie can get home by following trails 4, 3, 2, and 1.

因为使用了错误的方法来学习这个算法,被卡了三天始终学不会如何记忆和使用,苦思良久后终于明白,我根本不需要先记住每一步的操作才去编写代码,我可以直接写。于是我直接照着模板敲了出来了。我觉得照着模板敲并不是一个很坏的习惯,反而敲多几次会更加迅速地熟悉和掌握这个算法。恐怕,这个才是正确的学习方法吧。高中数学老师保哥也表达过类似的思想,学习最重要的是模仿。先理解,再模仿,继而熟悉与掌握。也许,这是一个非常强大的学习方法。
吹牛是一个很不好的行为,容易麻痹神经,容易让人飘起来,一飘就可能出大事。
#include<cstdio>
using namespace std;
const int inf = 0xFFFFFFF;
const int maxnum = 2000 + 10;
int bet[maxnum][maxnum], dist[maxnum];
void dijkstra(int n)
{
	bool s[maxnum];
	for (int i = 1; i <= n; i++)
	{
		dist[i] = bet[1][i];
		s[i] = 0;
	}
	dist[1] = 0;
	s[1] = 1;
	for (int i = 2; i <= n; i++)
	{
		int tmp = inf;
		int u = 1;
		for(int j =1;j<=n;j++)
			if (!s[j] && dist[j] < tmp)
			{
				u = j;
				tmp = dist[j];
			}
		s[u] = 1;
		for(int j=1;j<=n;j++)
		{
			if (!s[j] && bet[u][j] < inf&&dist[u] + bet[u][j] < dist[j])
				dist[j] = dist[u] + bet[u][j];
		}
	}
	return;
}




int main()
{
	
	int n, t, a, b, len;
	while (scanf("%d%d", &t, &n) == 2)
	{
		for (int i = 1; i <= n; i++)
		{
			for (int j = 1; j < n; j++)
			{
				bet[i][j] = bet[j][i] = inf;
			}
		}
		while (t--)
		{
			scanf("%d%d%d", &a, &b, &len);
			if (bet[a][b] > len) bet[a][b] = bet[b][a] = len;
		}
		dijkstra(n);
		printf("%d\n", dist[n]);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值