17秋季M-HouseBuilding

                            HouseBuilding
Have you ever played the video game Minecraft? This game has been one of the world's most popular game in recent years. The world of Minecraft is made up of lots of  1×1×1 1×1×1 blocks in a 3D map. Blocks are the basic units of structure in Minecraft, there are many types of blocks. A block can either be a clay, dirt, water, wood, air, ... or even a building material such as brick or concrete in this game. 


Figure 1: A typical world in Minecraft.


Nyanko-san is one of the diehard fans of the game, what he loves most is to build monumental houses in the world of the game. One day, he found a flat ground in some place. Yes, a super flat ground without any roughness, it's really a lovely place to build houses on it. Nyanko-san decided to build on a  n×m n×m big flat ground, so he drew a blueprint of his house, and found some building materials to build. 

While everything seems goes smoothly, something wrong happened. Nyanko-san found out he had forgotten to prepare glass elements, which is a important element to decorate his house. Now Nyanko-san gives you his blueprint of house and asking for your help. Your job is quite easy, collecting a sufficient number of the glass unit for building his house. But first, you have to calculate how many units of glass should be collected. 

There are  n n rows and  m m columns on the ground, an intersection of a row and a column is a  1×1 1×1 square,and a square is a valid place for players to put blocks on. And to simplify this problem, Nynako-san's blueprint can be represented as an integer array ci,j(1in,1jm) ci,j(1≤i≤n,1≤j≤m). Which  ci,j ci,j indicates the height of his house on the square of  i i-th row and  j j-th column. The number of glass unit that you need to collect is equal to the surface area of Nyanko-san's house(exclude the face adjacent to the ground).
Input
The first line contains an integer  T T indicating the total number of test cases. 
First line of each test case is a line with two integers  n,m n,m
The  n n lines that follow describe the array of Nyanko-san's blueprint, the  i i-th of these lines has  m m integers  ci,1,ci,2,...,ci,m ci,1,ci,2,...,ci,m, separated by a single space. 

1T50 1≤T≤50 
1n,m50 1≤n,m≤50 
0ci,j1000 0≤ci,j≤1000
Output
For each test case, please output the number of glass units you need to collect to meet Nyanko-san's requirement in one line.
Sample Input
2
3 3
1 0 0
3 1 2
1 1 0
3 3
1 0 1
0 0 0
1 0 1
Sample Output
30
20


        
 
   
   
Figure 2: A top view and side view image for sample test case 1.
       
这道题了,乍一看不就是求表面积,再一看发现每个位置放的积木块不一样,这就导致有的挨着有的没挨着,就会有侧面露出和没露出,萌新的我刚开始也不知道怎么办,下午睡完觉突然灵光一现。我们可以先假设所有的的积木除了地面都可以露出来,这样就是先积木块的数目算出来,再乘以5。当然不可能都漏出来,我们可以先从行看,每行相邻的比较看最小,给最小的乘以2这是因为一挨会导致两面都没有,列的和行一样,然后就是看高度的,我们发现只要有n积木叠加就会有n-1个面被盖住,这样可以算出被盖住的最后我们可以用总的减去被盖住的就是他的表面积。

   
   
#include<stdio.h>
int main()
{
    int a[50][50],t;
    scanf("%d",&t);
    while(t--)
    {
        int i,j,n,m;
        scanf("%d%d",&n,&m);
        for(i=0;i<n;i++)
            for(j=0;j<m;j++)scanf("%d",&a[i][j]);
        int t=0;
        for(i=0;i<n;i++)
            for(j=0;j<m-1;j++)
        {
            t=t+(a[i][j]<a[i][j+1]?a[i][j]:a[i][j+1])*2;
        }
        for(j=0;j<m;j++)
            for(i=0;i<n-1;i++)
        {
            t=t+(a[i][j]<a[i+1][j]?a[i][j]:a[i+1][j])*2;
        }
        int k=0;
        for(i=0;i<n;i++)
            for(j=0;j<m;j++)
        {
            if(a[i][j]>1)t=t+a[i][j]-1;
            k=k+a[i][j];
        }
        k=k*5;
        printf("%d\n",k-t);
    }
    return 0;
}

      
      

 






















  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值