House Building(UVALive 7194)

Description

Have you ever played the video game named Minecraft? This game has been one of the world’s most popular game in recent years. The world of Minecraft is made up of lots of 1×1×1 blocks in a 3D map. Blocks are the basic units of structure in Minecraft, there are many types of blocks. A block can either be a clay, dirt, water, wood, air, ... or even a building material
such as brick or concrete in this game.Nyanko-san is one of the diehard fans of the game, what he loves most is to build monumental houses in the world of the game. One day, he found a flat ground in some place. Yes, a super flat ground without any roughness, it’s really a lovely place to build houses on it. Nyanko-san decided to build on a n × m big flat ground, so he drew a blueprint of his house, and found some building materials to build.While everything seems goes smoothly, something wrong happened. Nyanko-san found out he had forgotten to prepare glass elements, which is a important element to decorate his house. Now Nyankosan gives you his blueprint of house and asking for your help. Your job is quite easy, collecting a
sufficient number of the glass unit for building his house. But first, you have to calculate how many units of glass should be collected.


There are n rows and m columns on the ground, an intersection of a row and a column is a 1 × 1
square, and a square is a valid place for players to put blocks on. And to simplify this problem, Nynako-
san’s blueprint can be represented as an integer array ci,j (1 ≤ i ≤ n, 1 ≤ j ≤ m). Which ci,j indicates
the height of his house on the square of i-th row and j-th column. The number of glass unit that
you need to collect is equal to the surface area of Nyanko-san’s house(exclude the face adjacent to the
ground).

Input

The first line contains an integer T indicating the total number of test cases. First line of each test case
is a line with two integers n, m. The n lines that follow describe the array of Nyanko-san’s blueprint,
the i-th of these lines has m integers ci,1, ci,2, …, ci,m, separated by a single space.
• 1 ≤ T ≤ 50
• 1 ≤ n, m ≤ 50
• 0 ≤ ci,j ≤ 1000

Output

For each test case, please output the number of glass units you need to collect to meet Nyanko-san’s
requirement in one line.

Sample Input

2
3 3
1 0 0
3 1 2
1 1 0
3 3
1 0 1
0 0 0
1 0 1

Sample Output

30
20

题解:

我的方法是算出来方块个数,减去底面积和重叠面积。

代码如下:

#include<algorithm>
#include<iostream>
#include<cstdlib>
#include<cstring>
#include<cstdio>
#include<string>
#include<vector>
#include<cmath>
#include<stack>
#include<queue>
#include<map>
#include<set>
#define max(a,b)   (a>b?a:b)
#define min(a,b)   (a<b?a:b)
#define swap(a,b)  (a=a+b,b=a-b,a=a-b)
#define maxn 27
#define N 100000000
#define INF 0x3f3f3f3f
#define mod 1001113
#define e  2.718281828459045
#define eps 1.0e18
#define PI acos(-1)
#define lowbit(x) (x&(-x))
#define read(x) scanf("%d",&x)
#define put(x) prllf("%d\n",x)
#define memset(x,y) memset(x,y,sizeof(x))
#define Debug(x) cout<<x<<" "<<endl
#define lson i << 1,l,m
#define rson i << 1 | 1,m + 1,r
#define ll long long
//std::ios::sync_with_stdio(false);
//cin.tie(NULL);
//const int maxn=;
using namespace std;

int a[101][101];
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        int n,m,dmj=0,cd=0,s=0;
        cin>>n>>m;
        for(int i=0;i<n;i++)
            for(int j=0;j<m;j++)
            {
                cin>>a[i][j];
                if(a[i][j]>0)
                    dmj++;
                if(a[i][j]>1)
                    cd+=a[i][j]-1;
                s+=a[i][j];
            }
        for(int i=0;i<n;i++)
            for(int j=0;j<m-1;j++)
            {
                if(a[i][j]&&a[i][j+1])
                    cd+=min(a[i][j],a[i][j+1]);
            }
        for(int i=0;i<n-1;i++)
            for(int j=0;j<m;j++)
            {
                if(a[i][j]&&a[i+1][j])
                    cd+=min(a[i][j],a[i+1][j]);
            }
        cout<<s*6-dmj-2*cd<<endl;
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值