C Looooops POJ - 2115(扩展欧几里德 + 解同余方程)

C Looooops
Time Limit: 1000MS      
Memory Limit: 65536K
Total Submissions: 29515        
Accepted: 8529

Description
A Compiler Mystery: We are given a C-language style for loop of type

    for (variable = A; variable != B; variable += C)
    statement;


I.e., a loop which starts by setting variable to value A and while variable is not equal to B, repeats statement followed by increasing the variable by C. We want to know how many times does the statement get executed for particular values of A, B and C, assuming that all arithmetics is calculated in a k-bit unsigned integer type (with values 0 <= x < 2k) modulo 2k.

Input

The input consists of several instances. Each instance is described by a single line with four integers A, B, C, k separated by a single space. The integer k (1 <= k <= 32) is the number of bits of the control variable of the loop and A, B, C (0 <= A, B, C < 2k) are the parameters of the loop.

The input is finished by a line containing four zeros.

Output

The output consists of several lines corresponding to the instances on the input. The i-th line contains either the number of executions of the statement in the i-th instance (a single integer number) or the word FOREVER if the loop does not terminate.

Sample Input

3 3 2 16
3 7 2 16
7 3 2 16
3 4 2 16
0 0 0 0

Sample Output

0
2
32766
FOREVER

题意:
有一个在k位无符号整数下的模型:for (variable = A; variable != B; variable += C) statement; 问循环的次数,若“永不停息”(←_←)*,就输出”FOREVER”。

思路:用拓展欧几里德方法求出gcd最大公因数,再利用同余性质转化,求同余方程,或者不定方程。其中题目可化为 a+cx=b(mod 2^k) → cx=b-a(mod 2^k),求最小正整数解。也是求解同余方程。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
#include<algorithm>
#include<vector>
#include<queue>
#include<stack>
#define ll long long

using namespace std;

ll ex_gcd(ll a, ll b, ll &x, ll &y)
{
    if(b == 0){
        x = 1;
        y = 0;
        return a;
    } else {
       ll r = ex_gcd(b, a%b, y, x);
       y -= x*(a/b);
       return r;
    }
}


ll line_mod_equation(ll a, ll b, ll n) {
    ll x,y;
    ll d = ex_gcd(a, n, x, y);
    ll ans;
    if(b%d == 0){
        x%=n;
        x+=n;
        x%=n;
        ll t = n/d;
        ans = (x*(b/d)%t + t)%t;
        return ans;
    }
    else
    return -1;
}


int main()
{
   ll aa,bb,cc,dd;
   scanf("%lld%lld%lld%lld",&aa,&bb,&cc,&dd);
   while(aa!=0||bb!=0||cc!=0||dd!=0)
   {
      ll a = cc;
      ll b = bb - aa;
      ll p = (ll) 1<<dd;
      ll ans = line_mod_equation(a,b,p);
      if(ans == -1) puts("FOREVER");
      else printf("%lld\n",ans);
      scanf("%lld%lld%lld%lld",&aa,&bb,&cc,&dd);
   }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值