Euclid's Game HDU - 1525

Euclid’s Game
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4147 Accepted Submission(s): 1967

Problem Description
Two players, Stan and Ollie, play, starting with two natural numbers. Stan, the first player, subtracts any positive multiple of the lesser of the two numbers from the greater of the two numbers, provided that the resulting number must be nonnegative. Then Ollie, the second player, does the same with the two resulting numbers, then Stan, etc., alternately, until one player is able to subtract a multiple of the lesser number from the greater to reach 0, and thereby wins. For example, the players may start with (25,7):

25 7
11 7
4 7
4 3
1 3
1 0

an Stan wins.

Input
The input consists of a number of lines. Each line contains two positive integers giving the starting two numbers of the game. Stan always starts.

Output
For each line of input, output one line saying either Stan wins or Ollie wins assuming that both of them play perfectly. The last line of input contains two zeroes and should not be processed.

Sample Input

34 12
15 24
0 0

Sample Output

Stan wins
Ollie wins

Source
University of Waterloo Local Contest 2002.09.28

题意:

题目给出了两个正数a.b 每次操作,大的数减掉小的数的整数倍。一个数变为0 的时候结束。
谁先先把其中一个数减为0的获胜。问谁可以赢。Stan是先手。

分析:
假设两个数为(a,b)(a>=b)
如果a==b. 那么肯定是先手获胜。一步就可以减为(0,b)
如果a%b==0.就是a是b的倍数,那么也是先手获胜。

如果a>=2*b. 那么 那个人肯定知道a%b,b是必胜态还是必败态。如果是必败态,先手将(a,b)变成(a%b,b),那么先手肯定赢。如果是必胜态,先手将(a,b)变成(a%b+b,b).那么对手只有将这两个数变成a%b,b,先手获胜。

如果是b < a < 2*b 那么只有一条路:变成(a-b,b) (这个时候0 <(a-b)< b)。这样一直下去看谁先面对上面的必胜状态。
所以假如面对b < a < 2*b的状态,就先一步一步走下去。直到面对一个a%b==0 || a >=2*b的状态。

代码:

#include<iostream>
#include<cstring>
#include<cstdio>
#include<string>
#include<algorithm>
#include<queue>
#include<stack>
#include<iomanip>
#include<cmath>

using namespace std;
/**
    2018/1/21
    未完成
    **/
int a,b;

int main()
{
    while(scanf("%d%d",&a,&b))
    {
        if(a == 0&& b == 0) break;
        bool f = true;
        if(a < b) swap(a,b);
        while(b){
          if(a%b == 0|| a >= 2*b) break;
          a %= b;
          if(a < b) swap(a,b);
          f = !f;
        }
        if(f) puts("Stan wins");
        else puts("Ollie wins");
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值