HDU 1548 A strange lift(BFS)

Problem Description

There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 <= Ki <= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press the button “UP” , you will go up Ki floor,i.e,you will go to the i+Ki th floor,as the same, if you press the button “DOWN” , you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the lift can’t go up high than N,and can’t go down lower than 1. For example, there is a buliding with 5 floors, and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining from the 1 st floor,you can press the button “UP”, and you’ll go up to the 4 th floor,and if you press the button “DOWN”, the lift can’t do it, because it can’t go down to the -2 th floor,as you know ,the -2 th floor isn’t exist.
Here comes the problem: when you are on floor A,and you want to go to floor B,how many times at least he has to press the button “UP” or “DOWN”?

Input

The input consists of several test cases.,Each test case contains two lines.
The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which describe above,The second line consist N integers k1,k2,…kn.
A single 0 indicate the end of the input.

Output

For each case of the input output a interger, the least times you have to press the button when you on floor A,and you want to go to floor B.If you can’t reach floor B,printf “-1”.

Sample Input

5 1 5
3 3 1 2 5
0

Sample Output

3

题目大意:给定n个数,比如当n = 5的时候,给数组r存上3 3 1 2 5,表示每一层楼电梯可以移动的距离。比如当我从第1层楼出发要到第5层楼的时候,在第1层楼我只能往上移动3层或往下移动3层,但我不可能往下到-2层,所以只能从第一层楼到第四层楼。同理,我在第四层楼也不能在网上移动2层了,所以只能往下移动2层到达第二层楼,在第二层楼我再往上移动3层就可以到达第五层楼这个目标楼层了。
此时花费了3次移动,所以输出3

思路:用广搜。因为每次可以往上移或往下移r[i]层,所以你在每种楼层都会有两种选择方案。其实用dfs也很好做,但这种找最短距离的题一般用广搜更好!

AC代码:

/*
如果不能移动到,打印-1 
*/
#include<iostream>
#include<memory.h>
#include<queue>
using namespace std;

int n;
const int maxn = 250;
int r[maxn];
int tag[maxn];

struct Node{
	int floor;
	int step;
	Node(int floor, int step)
	{
		this->floor = floor;
		this->step = step;
	}
};

bool panduan(int floor)
{
	if(floor < 1 || floor > n)
		return false;
	if(tag[floor] == 1)
		return false;
	return true;
}

int bfs(int a, int b)
{
	queue<Node> q;
	q.push(Node(a, 0));
	tag[a] = 1;
	while(!q.empty())
	{
		Node f = q.front();
		if(f.floor == b)
			return f.step;
		
		int next;
		if(panduan(f.floor + r[f.floor]))
		{
			next = f.floor + r[f.floor];	
			tag[next] = 1;
			q.push(Node(next, f.step + 1));
		}
		if(panduan(f.floor - r[f.floor]))
		{
			next = f.floor - r[f.floor];
			tag[next] = 1;
			q.push(Node(next, f.step + 1));
		}
		q.pop();
	}
	return -1;
}

void Clear()			//换成memset初始化又是WA。。。 
{
	for(int i = 1;i <= n;i++)
	{
		tag[i] = 0;
	}
}

int main()
{
	int a, b;
	while(scanf("%d", &n) && n != 0)
	{
		Clear();
		cin >> a >> b;
		for(int i = 1;i <= n;i++)
		{
			cin >> r[i];
		}
		cout << bfs(a, b) << endl;
	}
	return 0;
}

Clear函数如果换成memset函数初始化又是WA,以后还是用自己编的函数吧。。。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值