1100 Mars Numbers (20分)

People on Mars count their numbers with base 13:
Zero on Earth is called “tret” on Mars.
The numbers 1 to 12 on Earth is called “jan, feb, mar, apr, may, jun, jly, aug, sep, oct, nov, dec” on Mars, respectively.
For the next higher digit, Mars people name the 12 numbers as “tam, hel, maa, huh, tou, kes, hei, elo, syy, lok, mer, jou”, respectively.
For examples, the number 29 on Earth is called “hel mar” on Mars; and “elo nov” on Mars corresponds to 115 on Earth. In order to help communication between people from these two planets, you are supposed to write a program for mutual translation between Earth and Mars number systems.
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (<100). Then N lines follow, each contains a number in [0, 169), given either in the form of an Earth number, or that of Mars.
Output Specification:
For each number, print in a line the corresponding number in the other language.
Sample Input:
4
29
5
elo nov
tam

Sample Output:
hel mar
may
115
13

#include<stdio.h>
#include<iostream>
#include<string>
#include<map>
using namespace std;
//0~12的火星文
string unitDigit[13] = {"tret","jan", "feb", "mar", "apr", "may", "jun", "jly", "aug", 
                         "sep", "oct", "nov", "dec"} ;
//13的[0, 12]倍的火星文 
string tenDigit[13] = {"tret", "tam", "hel", "maa", "huh", "tou", "kes", "hei", "elo", 
                         "syy", "lok", "mer", "jou"}; 
string numTostr[170];  //数字->火星文
map<string, int> strTonum;  //火星文->数字

void init() {  //打表,将0~168之间的火星文向数字转换,以及数字向火星文转换一一对应 
	for(int i = 0; i < 13; ++i) {  //初始化每个数字对应的个位 
		numTostr[i] = unitDigit[i];
		strTonum[unitDigit[i]] = i;
		numTostr[i * 13] = tenDigit[i];
		strTonum[tenDigit[i]] = i * 13;
	}
	//下面的循环从1开始的原因是,上面的循环已经将不满13的处理完了 
	for(int i = 1; i < 13; ++i) {
		for(int j = 1; j < 13; ++j) {
			string str = tenDigit[i] + " " + unitDigit[j];
			numTostr[i * 13 + j] = str;
			strTonum[str] = i * 13 + j;
		} 
	}
} 

int main() {
	init();
	int n;
	cin >> n;
    getchar(); //接收输入查询个数之后的回车,如果不接收,第一次str会接收回车,并输出0 
	for(int i = 0; i < n; ++i) {
		string str;
		//cin >> str;  //用cin会有一些数据点不通过,因为cin无法接受空格,火星文有空格
		             //而且string型数据不能用scanf 
		getline(cin, str);  //接收一整行的输入 
		if(str[0] >= '0' && str[0] <= '9') {
			int num = 0;
			for(int j = 0; j < str.length(); ++j) {
				num = num * 10 + (str[j] - '0');
			}
			cout << numTostr[num] << endl;
		} else {
			cout << strTonum[str] << endl;
		}
	}
	
	
	return 0;
} ```

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值