1020 Tree Traversals (25 分)树的遍历,后序中序层序,bfs

1020 Tree Traversals (25 分)
Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7
Sample Output:
4 1 6 3 5 7 2

后序+中序—>层序
一开始想转先序,用二叉树数组记录构造的树,但是发现会很大,最大节点编号为2^30-1(30个数,可能全为右节点)
所以我用的广搜。。

#include<iostream>
#include<cstdio>
#include<queue>
using namespace std;
int n,post[35],in[35];
struct Node
{
	int ps,pe;
	int is,ie;
}q;
Node t;
queue<Node>Q;
int res[35],ans=0;
int main()
{
	scanf("%d",&n);
	for(int i=1;i<=n;i++)scanf("%d",&post[i]);
	for(int i=1;i<=n;i++)scanf("%d",&in[i]);
	q.ps=1,q.pe=n;
	q.is=1,q.ie=n;
	Q.push(q);
	while(!Q.empty())
	{
		q=Q.front();
		Q.pop();
		res[++ans]=post[q.pe];
//		printf("%d ",post[q.pe]);
		int mid;
		for(mid=q.is;mid<=q.ie;mid++)
		{
			if(in[mid]==post[q.pe])break;
		}
		/*放左边点*/
		t.is=q.is;
		t.ie=mid-1;
		t.ps=q.ps;
		t.pe=q.ps+(t.ie-t.is);
		if(t.is<=t.ie&&t.ps<=t.pe)Q.push(t);
		/*放右边点*/
		t.is=mid+1;
		t.ie=q.ie;
		t.ps=t.pe+1;
		t.pe=q.pe-1;
		if(t.is<=t.ie&&t.ps<=t.pe)Q.push(t);
	}
	for(int i=1;i<ans;i++)printf("%d ",res[i]);
	printf("%d\n",res[ans]);
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值