Flip Game 【BFS】

Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it's black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules:
  1. Choose any one of the 16 pieces.
  2. Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).

Consider the following position as an example:

bwbw
wwww
bbwb
bwwb
Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become:

bwbw
bwww
wwwb
wwwb
The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal.
Input
The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.
Output
Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it's impossible to achieve the goal, then write the word "Impossible" (without quotes).
Sample Input
bwwb
bbwb
bwwb
bwww
Sample Output
4


题意:

给你4*4的棋子,可以翻转任意棋子及其四周(必须同时进行),问最少几次可以使棋子颜色一样。每枚棋子正反的颜色相反。

分析:

优先想到BFS,因为可以认为是走迷宫的变形。显然如果可以达到最终状态为纯色,必定是可以通过有限步骤time达到的。

则棋子翻转可能有pow(16,time)次。比如第一次可能选择的棋子有十六种,第二次同样也是十六种....(或者可以用递归解决)

所以仅仅需要把每次翻转完的状态记录下来即可,为了达到有限步骤,必须保证状态不重复。(或者说只有不重复的加入队列)


如果用4*4数组储存状态,可能会向系统请求pow(16,time)*4*4*4字节的内存来储存状态,其次判断状态是否为纯色复杂度比较高(可能需要两个for),因此,可借鉴bit法。将16枚棋子用两个字节表示。


废话少说,ac代码如下:

# include<cstdio>
# include<queue>
# include<cstring>

using namespace std;

struct node
{
	int x,i,time;
	node(){}
	node(int a,int b,int c)
	{
		x=a;
		i=b;
		time=c;
	}
 };
 bool vis[10000000];
 int o=0;
queue<node> que;
node next;


 
 void just(int i,node now)
 {
	int r=i/4,c=i%4;
	next=now;
	next.x^=0x1<<i;
	if(r>0)
		next.x^=0x1<<i-4;
	if(r<3)
		next.x^=0x1<<i+4;
	if(c>0)
		next.x^=0x1<<i-1;
	if(c<3)
		next.x^=0x1<<i+1;
	next.i=i;
	next.time=now.time+1;			
 }
 

int bfs()
{
	if(o==0x0||o==0xffff)
	{
		printf("0\n");
		return 1;
	 } 
	que.push(node(o,-1,0));
	while(!que.empty())
	{
		for(int i=0;i<16;i++)
		{
			if(que.front().i==i)
				continue; 
			just(i,que.front());
			if(!vis[next.x])
				que.push(next);
			vis[next.x]=true;	
			if(next.x==0x0||next.x==0xffff)
			{
				printf("%d\n",next.time);
				return 1;
			}
		}
		que.pop();
	}
	printf("Impossible\n");
	return 0;
} 
 
int main()
{
	char c[4][4];
	memset(vis,false,sizeof(vis));
	for(int i=0;i<4;i++)
	{
		scanf("%s",c[i]);
		for(int j=0;j<4;j++)
		{
			if(c[i][j]=='b')
				o|=0x1<<i*4+j;
		} 
	}
	bfs();
	return 0;
} 
//0011
//0111
//1111 
//1111

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值