ACM训练日志31-线段树应用

题目:poj3468
Description

You have N integers, A1, A2, … , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1, A2, … , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
“C a b c” means adding c to each of Aa, Aa+1, … , Ab. -10000 ≤ c ≤ 10000.
“Q a b” means querying the sum of Aa, Aa+1, … , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4
Sample Output

4
55
9
15
Hint

The sums may exceed the range of 32-bit integers.

题意: 输入 n, m表初始有 n 个数, 接下来 m 行输入, Q x y 表示询问区间 [x, y]的和;
C x y z 表示区间 [x, y] 内所有数加上 z

题目链接:http://poj.org/problem?id=3468

#include <iostream>
#include <cstdio>
#include <cstring>
#include <stack>
#include <queue>
#include <map>
#include <set>
#include <vector>
#include <cmath>
#include <algorithm>
using namespace std;
const double eps = 1e-6;
const double pi = acos(-1.0);
const int INF = 0x3f3f3f3f;
const int MOD = 1000000007;
#define ll long long
#define CL(a,b) memset(a,b,sizeof(a))
#define MAXN 100010
 
struct node
{
    int l,r;
    ll s,add;//add为每次加的数
}t[MAXN<<2];
int hh[MAXN];
int n,q;
ll ans;
 
void build(int l, int r, int i)
{
    t[i].l = l;
    t[i].r = r;
    t[i].add = 0;
    if(l == r) return ;
    int mid = (l+r)>>1;
    build(l, mid, i<<1);
    build(mid+1, r, i<<1|1);
    t[i].s = t[i<<1].s+t[i<<1|1].s;
}
 
void update(int l, int r, int add, int i)
{
    if(t[i].l>r || t[i].r<l) return ;
    if(t[i].l>=l && t[i].r<=r)

        {
            t[i].s += (t[i].r-t[i].l+1)*add;
            t[i].add += add;
            return ;
        }
        if(t[i].add)
        {
            t[i<<1].s += (t[i<<1].r-t[i<<1].l+1)*t[i].add;
            t[i<<1].add += t[i].add;
            t[i<<1|1].s += (t[i<<1|1].r-t[i<<1|1].l+1)*t[i].add;
            t[i<<1|1].add += t[i].add;
            t[i].add = 0;
        }
        update(l, r, add, i<<1);
        update(l, r, add, i<<1|1);
        t[i].s = t[i<<1].s+t[i<<1|1].s;
    }
     
    void query(int l, int r, int i)
    {
        if(t[i].l>r || t[i].r<l) return ;
        if(t[i].l>=l && t[i].r<=r)
        {
            ans += t[i].s;
            return ;
        }
        if(t[i].add)
        {
            t[i<<1].s += (t[i<<1].r-t[i<<1].l+1)*t[i].add;
            t[i<<1].add += t[i].add;
            t[i<<1|1].s += (t[i<<1|1].r-t[i<<1|1].l+1)*t[i].add;
            t[i<<1|1].add += t[i].add;
            t[i].add = 0;
        }
        query(l, r, i<<1);
        query(l, r, i<<1|1);
        t[i].s = t[i<<1].s+t[i<<1|1].s;
    }
     
    int main()
    {
        int a,b,c;
        ll k;
        char ch;
        while(scanf("%d%d",&n,&q)==2)
        {
            for(int i=1; i<=n; i++)
                scanf("%d",&hh[i]);
            build(1, n, 1);
            for(int i=1; i<=n; i++)
                update(i, i, hh[i], 1);
            while(q--)
            {
                getchar();
                scanf("%c",&ch);
                if(ch == 'C')
                {
                    scanf("%d%d%d",&a,&b,&c);
                    update(a, b, c, 1);
                }
                if(ch == 'Q')
                {
                    ans = 0;
                    scanf("%d%d",&a,&b);
                    query(a, b, 1);
                    printf("%lld\n",ans);
                }
            }
        }
        return 0;
    }
    //代码来自:https://blog.csdn.net/d_x_d/article/details/50387645
    ```
#include<bits/stdc++.h>
#include <stdio.h>
#define ll long long
#define lson l, mid, rt << 1
#define rson mid + 1, r, rt << 1 | 1
using namespace std;

const int MAXN = 1e5 + 10;
ll sum[MAXN << 2];
ll add[MAXN << 2];

void push_up(int rt){//向上更新
    sum[rt] = sum[rt << 1] + sum[rt << 1 | 1];
}

void push_down(int rt, int m){
    if(add[rt]){//若有标记,则将标记向下移动一层
        add[rt << 1] += add[rt];
        add[rt << 1 | 1] += add[rt];
        sum[rt << 1] += (m - (m >> 1)) * add[rt];
        sum[rt << 1 | 1] += (m >> 1) * add[rt];
        add[rt] = 0;//取消本层标记
    }
}

void build(int l, int r, int rt){//建树
    add[rt] = 0;
    if(l == r){
        scanf("%lld", &sum[rt]);
        return;
    }
    int mid = (l + r) >> 1;
    build(lson);
    build(rson);
    push_up(rt);//向上更新
}

void update(int L, int R, ll key, int l, int r, int rt){//区间更新
    if(L <= l && R >= r){
        sum[rt] += (r - l + 1) * key;
        add[rt] += key;
        return;
    }
    push_down(rt, r - l + 1);//向下更新
    int mid = (l + r) >> 1;
    if(L <= mid) update(L, R, key, lson);
    if(R > mid) update(L, R, key, rson);
    push_up(rt);//向上更新
}

ll query(int L, int R, int l, int r, int rt){//区间求和
    if(L <= l && R >= r) return sum[rt];
    push_down(rt, r - l + 1);//向下更新
    int mid = (l + r) >> 1;
    ll ans = 0;
    if(L <= mid) ans += query(L, R, lson);
    if(R > mid) ans += query(L, R, rson);
    return ans;
}

int main(void){
    int n, m;
    scanf("%d%d", &n, &m);
    build(1, n, 1);
    while(m--){
        char str[3];
        int x, y;
        ll z;
        scanf("%s", str);
        if(str[0] == 'C'){
            scanf("%d%d%lld", &x, &y, &z);
            update(x, y, z, 1, n, 1);
        }else{
            scanf("%d%d", &x, &y);
            printf("%lld\n", query(x, y, 1, n, 1));
        }
    }
}
//代码来自:http://www.cnblogs.com/geloutingyu/p/7003377.html
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值