A Simple Problem with Integers POJ - 3468(树状数组)

You have N integers, A1, A2, … , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input
The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1, A2, … , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
“C a b c” means adding c to each of Aa, Aa+1, … , Ab. -10000 ≤ c ≤ 10000.
“Q a b” means querying the sum of Aa, Aa+1, … , Ab.

Output
You need to answer all Q commands in order. One answer in a line.

Sample Input
10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4
Sample Output
4
55
9
15
Hint
The sums may exceed the range of 32-bit integers.

思路:我们先看一个简化的问题,如果询问的不是区间范围和,而是一个单点值是怎么样的?

那么对于C操作,我们可以很自然的想到区间覆盖问题的问题,

我们假设一个数组 c
那么对于操作C l r d等价于 c[l]+=d,c[r+1]=d ,所以对于某个单点x的值,相当于求1到x的c前缀和在加上本身的值。二前缀和可以通过树状数组来快租求得。
那么对于区间和呢?也就是本题要求的
那么我们可以先看 a[1...x] 的整体区间值。
易知:

i=1xj=1ib[j]

化简为:
(x+1)i=1xb[i]i=1xib[i]

所以我们就可以用两个树状数组来维护两个前缀和啦。

代码:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<cstring>
#include<vector>
#define maxx 100005
using namespace std;
int n,q;
long long a[maxx];
long long  c[2][maxx];
void change(int k,int x,int p)
{
    for(;x<=n;x+=x&-x)c[k][x]+=p;
}

long long query(int k,int x)
{
    long long ans=0;
    for(;x;x-=x&-x)ans+=c[k][x];
    return ans;
}
long long query(int x)
{
    return a[x]+(x+1)*query(0,x)-query(1,x);
}
int main()
{
    cin>>n>>q;
    for(int i=1;i<=n;i++)
    {
        scanf("%lld",a+i);
        a[i]+=a[i-1];
    }
    char s[3];
    int l,r,d;
    while(q--)
    {
        scanf("%s",s);
        if(s[0]=='Q')
        {
            scanf("%d%d",&l,&r);
            printf("%lld\n",query(r)-query(l-1));
        }
        else
        {
            scanf("%d%d%d",&l,&r,&d);
            change(0,l,d);
            change(0,r+1,-d);
            change(1,l,l*d);
            change(1,r+1,-(r+1)*d);
        }
    }
    return 0;
}
  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值