【算法练习】动态规划/LCS 百练poj1458:Common Subsequence

题目地址:http://bailian.openjudge.cn/practice/1458

友情链接:百练poj4007:计算字符串距离,可以进行比较:https://blog.csdn.net/weixin_40760678/article/details/98473053

1458:Common Subsequence

 

总时间限制: 

1000ms

 

内存限制: 

65536kB

描述

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, ..., ik > of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.

输入

The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.

输出

For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

样例输入

abcfbc         abfcab
programming    contest 
abcd           mnp

样例输出

4
2
0

题目理解:一个非常典型的最长公共子序列的问题

一开始开dp数组开到10010,结果TLE ,开到1010就AC了.

一开始dp可以直接全部填0,或者 dp[0][i]=dp[i][0]=0  //前一种方法可能会比较耗时

AC代码

#include<iostream>
#include <string.h>
using namespace std;
//LCS 最长公共子序列
int dp[10010][10010];
string a,b;
int main(){
    while(cin>>a>>b){
        memset(dp,0, sizeof(dp));
        int len1=a.size();
        int len2=b.size();
        for(int i=1;i<=len1;i++){
            for(int j=1;j<=len2;j++){
                if(a[i-1]==b[j-1]){
                    dp[i][j]=dp[i-1][j-1]+1;
                }
                else{
                    dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
                }
            }
        }
        cout<<dp[len1][len2]<<endl;

    }

    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值