hdu1016

Prime Ring Problem

Time Limit: 2000 MS Memory Limit: 32768 KB

64-bit integer IO format: %I64d , %I64u Java class name: Main

[Submit] [Status] [Discuss]

Description

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.


Input

n (0 < n < 20).

Output

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.

Sample Input

6
8

Sample Output

Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2

Source

Asia 1996, Shanghai (Mainland China)
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<queue>
#include<string.h>
#include<math.h>
using namespace std;
int vis[25];
int a[25];
int n;
int sushu(int su)
{
    for(int i=2;i<=sqrt(su);i++)
    {
        if(su%i==0) return 0;
    }
    return 1;
}
void dfs(int step)
{
    if(step==n+1)
    {
        if(sushu(a[1]+a[n])){
        for(int i=1;i<=n;i++){
        if(i==1)
        printf("%d",a[i]);
        else printf(" %d",a[i]);
        }
        printf("\n");
        }
        return ;
    }
    for(int i=1;i<=n;i++)
    {
        if(!vis[i]&&sushu(i+a[step-1]))
        {
            a[step] = i;
            vis[i] = 1;
            dfs(step+1);
            if(i!=1)
            vis[i] = 0;
        }
    }
}
int main()
{
    int d=1;
    while(~scanf("%d",&n))
    {
        memset(vis,0,sizeof(vis));
        memset(a,0,sizeof(a));
        printf("Case %d:\n",d++);
        dfs(1);
        printf("\n");
    }
    return 0;
}
不要在找到一个排列是去判断相邻的两个数的和是不是素数,这样会超时,虽然只有20个树,应该在dfs 的时候就判断i+a【step-1】是不是素数,如果是素数就继续往下搜。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值