拓扑排序 (判断有向图是否存在回环)

Legal or Not

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 9777    Accepted Submission(s): 4541


Problem Description
ACM-DIY is a large QQ group where many excellent acmers get together. It is so harmonious that just like a big family. Every day,many "holy cows" like HH, hh, AC, ZT, lcc, BF, Qinz and so on chat on-line to exchange their ideas. When someone has questions, many warm-hearted cows like Lost will come to help. Then the one being helped will call Lost "master", and Lost will have a nice "prentice". By and by, there are many pairs of "master and prentice". But then problem occurs: there are too many masters and too many prentices, how can we know whether it is legal or not?

We all know a master can have many prentices and a prentice may have a lot of masters too, it's legal. Nevertheless,some cows are not so honest, they hold illegal relationship. Take HH and 3xian for instant, HH is 3xian's master and, at the same time, 3xian is HH's master,which is quite illegal! To avoid this,please help us to judge whether their relationship is legal or not. 

Please note that the "master and prentice" relation is transitive. It means that if A is B's master ans B is C's master, then A is C's master.
 

Input
The input consists of several test cases. For each case, the first line contains two integers, N (members to be tested) and M (relationships to be tested)(2 <= N, M <= 100). Then M lines follow, each contains a pair of (x, y) which means x is y's master and y is x's prentice. The input is terminated by N = 0.
TO MAKE IT SIMPLE, we give every one a number (0, 1, 2,..., N-1). We use their numbers instead of their names.
 

Output
For each test case, print in one line the judgement of the messy relationship.
If it is legal, output "YES", otherwise "NO".
 

Sample Input
 
 
3 2 0 1 1 2 2 2 0 1 1 0 0 0
 

Sample Output
 
 
YES NO
 

Author
QiuQiu@NJFU
 

Source

 题目大意: 几对师徒关系问是否合法,若存在回路则不合法。

//111.CPP
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <map>
#include <queue>
#include <vector>
#define LL long long
#define Max(a,b) a>b?a:b
#define Min(a,b) a<b?a:b
#define mem(a,b) memset(a,b,sizeof(a))
using namespace std;
int ind[200];
int n,m;
vector<int>edge[105];
queue<int >q;
void init()//初始化 所有点的入度为0
{
   for(int i=0;i<n;i++)
   	 ind[i]=0;
   	mem(edge,0);
}
void add(int w,int v)//建图 记录每个点的入度
{
     edge[w].push_back(v);
     ind[v]++;
}
bool judge()
{
	for(int i=0;i<n;i++)//找到所有入度为0的点 
	{
		if(ind[i]==0)
		{
            q.push(i);
		}
	}
	int u;int cnt=0;
	while(!q.empty())
	{
        u=q.front();
        q.pop();
        cnt++;
        //cout<<u<<endl;
        int l=edge[u].size();
        for(int i=0;i<l;i++)//找到与以这个点为起点的点并且将入度减一
        {
        	int s=edge[u][i];
        	ind[s]--;
        	if(ind[s]==0) q.push(s);
        }

	}
	if(cnt==n) return true;//如果输出点的个数等于n则不存在回环
	return false;
}
int main()
{
	ios::sync_with_stdio(false);
	int u,v;
    while(cin>>n>>m)
    {
        if(n==0&&m==0)break;
    	init();
    	while(m--)
    	{
            cin>>u>>v;
            add(u,v);
    	}
    	if(judge())
    	{
    		cout<<"YES"<<endl;
    	}
    	else cout<<"NO"<<endl;
    }
}


拓扑排序:

http://blog.csdn.net/qq_35644234/article/details/60578189

拓扑排序是一种常用的有向无环图(DAG)排序算法,可用于判断有向图是否存在环。下面是拓扑排序判断有向图是否有环的概要设计: 1. 统计每个节点的入度,入度为 0 的节点加入队列中。 2. 从队列中取出一个入度为 0 的节点,并将该节点从图中删除。 3. 遍历该节点的所有邻居节点,将其入度减 1。 4. 如果有邻居节点入度为 0,则加入队列中。 5. 重复步骤 2-4 直到队列为空。 6. 如果所有节点都被访问过,则说明不存在环;否则存在环。 具体步骤如下: 1. 初始化一个队列 Q,并统计每个节点的入度。 2. 将入度为 0 的节点加入队列 Q 中。 3. 当队列 Q 不为空时,执行以下操作: a. 从队列 Q 中取出一个入度为 0 的节点; b. 将该节点从图中删除; c. 遍历该节点的所有邻居节点,将其入度减 1; d. 如果有邻居节点入度为 0,则加入队列 Q 中。 4. 如果所有节点都被访问过,则说明不存在环;否则存在环。 需要注意的是,如果图中存在环,则无法进行拓扑排序。因此,在实现拓扑排序算法时,需要先判断图中是否存在环,如果存在环,则直接返回有环的结果,否则进行拓扑排序。 总之,拓扑排序是一种非常实用的图算法,可以用于判断有向图是否存在环,也可以用于确定任务的执行顺序和依赖关系等。在实际应用中,我们可以根据具体的问题场景,灵活地运用拓扑排序算法,提高工作效率和准确性。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值