HDU-1005 Number Sequence

Number Sequence

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2189 Accepted Submission(s): 814
 
Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 
Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 
Output
For each test case, print the value of f(n) on a single line.
 
Sample Input
1 1 3
1 2 10
0 0 0
 
Sample Output
2
5

题目大意

类似于斐波那契数列,通项公式为f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

解题思路

因为是mod7,尝试有循环节。因为第一第二项都是1,后面只要连续两次出现1,就是一次循环;

看了一些大佬的题解,据说所有的数列的循环节都可以看作是48,懒得推了。放我的暴力求循环节代码吧。

#include<algorithm>
#include<iostream>
#include<cstring>
using namespace std;
int f[1000];//瞎猜的1000 
int main()
{
	int a,b,n,i;
	while(cin>>a>>b>>n)
	{
		if(a==0&&b==0&&n==0)
		break;
		memset(f,0,sizeof(f));
		f[0]=1;//注意这里不能是从1开始,因为会出现n mod i=0的情况
		f[1]=1;
		if(n<=2)
		{
			cout<<"1"<<endl;
			continue;
		}
		for(i=2;i<1000;i++)
		{
			f[i]=(a*f[i-1]+b*f[i-2])%7;
		//	f[i]%=7;
			if(f[i]==f[i-1]&&f[i]==1)
			break;
		}
	//	cout<<i<<"  "<<f[i]<<endl;
		cout<<f[(n-1)%(i-1)]<<endl;
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值