Problem Description
In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.
|
Input
Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 10
7 on each line.
|
Output
The output contains the number of digits in the factorial of the integers appearing in the input. |
Sample Input
2 10 20 |
Sample Output
7 19 |
题目大意:
给出一个n,求 n! 的数位;
思路:
i 的数位等于 log10 ( i ) + 1, log 10 (N!)=log ( n ) + log ( n-1 ) + . . . + log 10 (1);
本来是用数组存储全部结果的,因为 n 最大是 1e7,所以会Memory Limit Exceeded ;
代码:
#include<algorithm>
#include<iostream>
#include<cmath>
#include<cstring>
using namespace std;
int main()
{
int t,n;
double k;
int ans,i;
while(cin>>t)
{
while(t--)
{
k=0;
cin>>n;
for(i=1;i<=n;i++)
k+=log10(i);
ans=(int)k+1;
cout<<ans<<endl;
}
}
return 0;
}