1045 Favorite Color Stripe-变种最长上升子序列

Eva is trying to make her own color stripe out of a given one. She would like to keep only her favorite colors in her favorite order by cutting off those unwanted pieces and sewing the remaining parts together to form her favorite color stripe.

It is said that a normal human eye can distinguish about less than 200 different colors, so Eva’s favorite colors are limited. However the original stripe could be very long, and Eva would like to have the remaining favorite stripe with the maximum length. So she needs your help to find her the best result.

Note that the solution might not be unique, but you only have to tell her the maximum length. For example, given a stripe of colors {2 2 4 1 5 5 6 3 1 1 5 6}. If Eva’s favorite colors are given in her favorite order as {2 3 1 5 6}, then she has 4 possible best solutions {2 2 1 1 1 5 6}, {2 2 1 5 5 5 6}, {2 2 1 5 5 6 6}, and {2 2 3 1 1 5 6}.

Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤200) which is the total number of colors involved (and hence the colors are numbered from 1 to N). Then the next line starts with a positive integer M (≤200) followed by M Eva’s favorite color numbers given in her favorite order. Finally the third line starts with a positive integer L (≤10
​4
​​ ) which is the length of the given stripe, followed by L colors on the stripe. All the numbers in a line a separated by a space.

Output Specification:
For each test case, simply print in a line the maximum length of Eva’s favorite stripe.

Sample Input:
6
5 2 3 1 5 6
12 2 2 4 1 5 5 6 3 1 1 5 6
Sample Output:
7

思路
题意就是给出Eva喜欢的颜色序列,再给出现有的序列,你应该找出一个可以不连续的子序列让它既满足只含有Eva喜欢的颜色并且这个颜色的排列顺序与给出的相同。

明天就考甲级了,逮出几个dp题练练手,突然发现这道题的新做法。
让我们来想一下最长上升子序列的求解过程,也是要找出一个可不连续的并且符合一定顺序的子序列,只不过这个顺序就是升序。同样对于这个问题,也是要找出符合一定顺序并且只包含特定元素的子序列。

样例中给出Eva想要的颜色序列2,3,1,5,6,我们可以看成1,2,3,4,5
现有的颜色序列2,2,4,1,5,5,6,3,1,1,5,6,对应上面的可以替换成1,1,0,3,4,4,5,2,3,3,4,5
然后直接求最长不下降子序列就行了。
应该注意的是初始时对于单个元素,dp[i]=1,但是对于Eva不喜欢的颜色替换成0后,对应的dp[i]应该等于0,因为不喜欢就不应该被算进去。

#include<bits/stdc++.h>
#define maxn 10000
using namespace std;
int id[210],data[maxn],dp[maxn];
int main(){
	int m,n1,n2,t;;
	cin >> m >> n1;
	for(int i=1;i<=n1;i++){
		cin >> t;
		id[t]=i;	//转换,这样不喜欢的颜色的id就是默认值0 
	}
	cin >> n2;
	for(int i=1;i<=n2;i++){
		cin >> t;
		data[i]=id[t];
		if(id[t])	//不为0时才是喜欢的颜色,才让dp[i]=1,否则dp[i]=0 
			dp[i]=1;
	}
	for(int i=1;i<=n2;i++){
		for(int j=i-1;j>=0;j--){
			if(data[j]<=data[i]&&data[i]!=0&&data[j]!=0)//注意判断非0,因为要求的是不下降序列,避免连续的0被算进去 
				dp[i]=max(dp[i],dp[j]+1);
		}
	}
	int ans=0;
	for(int i=1;i<=n2;i++)
		ans=max(ans,dp[i]);
	cout << ans;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值