Apple Catching-dp

It is a little known fact that cows love apples. Farmer John has two apple trees (which are conveniently numbered 1 and 2) in his field, each full of apples. Bessie cannot reach the apples when they are on the tree, so she must wait for them to fall. However, she must catch them in the air since the apples bruise when they hit the ground (and no one wants to eat bruised apples). Bessie is a quick eater, so an apple she does catch is eaten in just a few seconds.

Each minute, one of the two apple trees drops an apple. Bessie, having much practice, can catch an apple if she is standing under a tree from which one falls. While Bessie can walk between the two trees quickly (in much less than a minute), she can stand under only one tree at any time. Moreover, cows do not get a lot of exercise, so she is not willing to walk back and forth between the trees endlessly (and thus misses some apples).

Apples fall (one each minute) for T (1 <= T <= 1,000) minutes. Bessie is willing to walk back and forth at most W (1 <= W <= 30) times. Given which tree will drop an apple each minute, determine the maximum number of apples which Bessie can catch. Bessie starts at tree 1.
Input

  • Line 1: Two space separated integers: T and W

  • Lines 2…T+1: 1 or 2: the tree that will drop an apple each minute.
    Output

  • Line 1: The maximum number of apples Bessie can catch without walking more than W times.
    Sample Input
    7 2
    2
    1
    1
    2
    2
    1
    1
    Sample Output
    6
    题意:有两棵树,在T时间内每秒钟会随机从这两棵树中掉出一颗苹果,Bessie最多可以移动W步,问最后能获得的最多苹果数量
    思路:简单的dp题,可以用二维数组dp[i][j]来存储第i秒移动j步所获得的苹果的最大数量,看代码

#include<iostream>
using namespace std;
int dp[1010][50];	
int a[1010];
int main()
{
	int t,w;
	cin >> t >> w;
	for(int i=1;i<=t;i++)
		cin >> a[i];
	if(a[1]==1)
		dp[1][0]=a[1];//刚开始一秒内站在原地是否能接到苹果取决于a[1]代表的位置
	int ans;
	ans=dp[1][1]=1;//第1秒移动一步肯定至少能接到一个苹果 
	for(int i=2;i<=t;i++)
	{
		dp[i][0]=dp[i-1][0]+(a[i]%2);//第i秒移动0步接到的苹果数=
									//上一秒接到的+该秒苹果是否从1号树落下 
		for(int j=1;j<=w;j++)
		{
			dp[i][j]=max(dp[i-1][j],dp[i][j-1]);//第i秒移动j步接到的苹果数=
			//此时移动的情况(dp[i][j-1]+此时移动的位置有没有落苹果)+不移动的情况(dp[i-1][j]) 
			if((j+1)%2==a[i]%2)//如果此时移动的位置恰好是第i秒苹果掉下的位置
				dp[i][j]++;
			ans=max(dp[i][j],ans);
		}
	} 
	cout << ans;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值