PAT 1039 Course List for Student (25 分)

博客介绍了浙江大学的学生课程查询问题,给出输入输出规格,并对比了使用map、算法笔记方法和unordered_map进行数据结构优化时的性能差异,强调了在面临时间复杂度挑战时选择合适数据结构的重要性。
摘要由CSDN通过智能技术生成

1039 Course List for Student (25 分)

Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.


Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤40,000), the number of students who look for their course lists, and K (≤2,500), the total number of courses. Then the student name lists are given for the courses (numbered from 1 to K) in the following format: for each course i, first the course index i and the number of registered students N i N^i Ni (≤200) are given in a line. Then in the next line, N i N^i Ni​ student names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.


Output Specification:
For each test case, print your results in N lines. Each line corresponds to one student, in the following format: first print the student’s name, then the total number of registered courses of that student, and finally the indices of the courses in increasing order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.


Sample Input:

11 5
4 7
BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
1 4
ANN0 BOB5 JAY9 LOR6
2 7
ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6
3 1
BOB5
5 9
AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9

Sample Output:

ZOE1 2 4 5
ANN0 3 1 2 5
BOB5 5 1 2 3 4 5
JOE4 1 2
JAY9 4 1 2 4 5
FRA8 3 2 4 5
DON2 2 4 5
AMY7 1 5
KAT3 3 2 4 5
LOR6 4 1 2 4 5
NON9 0




解析

在这里插入图片描述
在这里插入图片描述
在这里插入图片描述
如上图:
第一张图是使用map<string,vector<int>>做的。第二张图是用算法笔记上面的方法做的。第三张图是用unordered_map<string,vector<int>>做的。
正如所见:使用map<string,vector<int>>可能会超时:大概50%的概率。使用算法笔记的做法不会超时。使用unordered_map<string,vector<int>>做是最快的。
这其实很关键:你准备hash的时候是使用map,还是unordered_map,还是自己写一个hash function。



这篇blog总结了,有兴趣的同学可以去看看:在PAT里使用map还是unordered_map?




第一份代码就是使用map<string,vector<int>>,第二份是算法笔记的。第三分只是把map<string,vector<int>>换成unordered_map<string,vector<int>>。




Code:

#include<vector>
#include<string>
#include<algorithm>
#include<iostream>
#include<iterator>
#include<map>
using namespace std;
int main()
{
	int N, K;
	cin >> N >> K;
	map<string, vector<int>> hash;
	for (int i = 0; i < K; i++) {
		int classindex, student;
		cin >> classindex >> student;
		string input;
		for (int i = 0; i < student; i++) {
			cin >> input;
			auto it = hash.find(input);
			if (it == hash.end())
				hash[input] = vector<int>{ classindex };
			else
				hash[input].push_back(classindex);
		}
	}
	string query;
	for (int i = 0; i < N; i++) {
		cin >> query;
		auto& data = hash[query];
		cout << query<<" "<<data.size();
		sort(data.begin(), data.end());
		for (auto x : data)
			cout << " " << x;
		cout << endl;
	}
} 



#include<vector>
#include<string>
#include<algorithm>
#include<iostream>
using namespace std;
const int M = 26 * 26 * 26 * 10 + 1;
vector<int> selectcourse[M];
int getID(const string& id) {
	int sum = 0;
	for (int i = 0; i < 3; i++)
		sum = sum * 26 + id[i] - 'A';
	sum = sum * 10 + id[3] - '0';
	return sum;
}
int main()
{
	int N, K;
	cin >> N >> K;
	for (int i = 0; i < K; i++) {
		int course, x;
		cin >> course >> x;
		string name;
		for (int j = 0; j < x; j++) {
			cin >> name;
			int id = getID(name);
			selectcourse[id].push_back(course);
		}
	}
	string query;
	for (int i = 0; i < N; i++) {
		cin >> query;
		int id = getID(query);
		sort(selectcourse[id].begin(), selectcourse[id].end());
		cout << query << " " << selectcourse[id].size();
		for (auto x : selectcourse[id])
			cout << " " << x;
		cout << endl;
	}
} 



#include<vector>
#include<string>
#include<algorithm>
#include<iostream>
#include<iterator>
#include<unordered_map>
using namespace std;
int main()
{
	int N, K;
	cin >> N >> K;
	unordered_map<string, vector<int>> hash;
	for (int i = 0; i < K; i++) {
		int classindex, student;
		cin >> classindex >> student;
		string input;
		for (int i = 0; i < student; i++) {
			cin >> input;
			auto it = hash.find(input);
			if (it == hash.end())
				hash[input] = vector<int>{ classindex };
			else
				hash[input].push_back(classindex);
		}
	}
	string query;
	for (int i = 0; i < N; i++) {
		cin >> query;
		auto& data = hash[query];
		cout << query << " " << data.size();
		sort(data.begin(), data.end());
		for (auto x : data)
			cout << " " << x;
		cout << endl;
	}
}
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值