(甲)1039 Course List for Student (25 分)(哈希表)

题目:

Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤40,000), the number of students who look for their course lists, and K (≤2,500), the total number of courses. Then the student name lists are given for the courses (numbered from 1 to K) in the following format: for each course i, first the course index i and the number of registered students N​i​​ (≤200) are given in a line. Then in the next line, N​i​​ student names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.

Output Specification:

For each test case, print your results in N lines. Each line corresponds to one student, in the following format: first print the student's name, then the total number of registered courses of that student, and finally the indices of the courses in increasing order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.

Sample Input:

11 5
4 7
BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
1 4
ANN0 BOB5 JAY9 LOR6
2 7
ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6
3 1
BOB5
5 9
AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9

Sample Output:

ZOE1 2 4 5
ANN0 3 1 2 5
BOB5 5 1 2 3 4 5
JOE4 1 2
JAY9 4 1 2 4 5
FRA8 3 2 4 5
DON2 2 4 5
AMY7 1 5
KAT3 3 2 4 5
LOR6 4 1 2 4 5
NON9 0

题意:

学校有4000名学生,有2500门课。

给你两个数字N,K,代表有N位学生,共有K门课,后面跟着K行代表每一门课的选课学生的情况;给你两个数字X,Y,代表课程X有Y名学生选择,后面是Y名学生的名字;最后面是N名需要查询选课结果学生的名字,要你输出:名字+选择课程总数+课程的编号;需要注意输出格式,注意空格;

思路:

第一反应就是想用map映射容器,把名字和选择的课程映射在一起,然后最后一组数据超时了,怎么也改不对,一直超时;用哈希表能做,需要自己构建一个哈希表,把键值和课程映射在一起;关于哈希表的键值不能相同,我们发现学生的姓名的格式都是一样的(三个大写字母+一个数字),那么这样就很方便我们构建哈希表了(姓名:ABC#,那么,键值=(A-'A')*26*26+(B-'A')*26+(C-'A')*10+#-'0');

正确代码如下:

#include<set>
#include<stdio.h>
#include<string>
#include<string.h>
#include<algorithm>
using namespace std;

int n,m;
int x,y;

int huan(char *k)//转换成哈希表的键值;
{
    int s=0;

    for(int i=0; i<3; i++)
    {
        s=s*26+k[i]-'A';
    }
    s=s*10+k[3]-'0';
    return s;
}

set<int>w[180000];

int main()
{
    char a[5];
    scanf("%d %d",&n,&m);
    for(int i=0; i<m; i++)
    {
        scanf("%d %d",&x,&y);
        for(int j=0; j<y; j++)
        {
            scanf("%s",a);
            int qq=huan(a);
            w[qq].insert(x);//选择的课程加入;
        }
    }
    for(int i=0; i<n; i++)
    {
        scanf("%s",a);
        int qq=huan(a);
        printf("%s %d",a,w[qq].size());
        set<int>::iterator it;
        for(it=w[qq].begin(); it!=w[qq].end(); it++)
        {
            printf(" %d",*it);
        }
        printf("\n");
    }
    return 0;
}

错误代码如下:

#include<stdio.h>
#include<string.h>
#include<map>
#include<string>
#include<iostream>
#include<algorithm>
using namespace std;

int n,m;
int x,y;

string s;
map<string,int>mp[2510];
int book[40010];
string q[40010];
int t[40010];

int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        memset(book,0,sizeof book);
        for(int i=0; i<m; i++)
        {
            scanf("%d%d",&x,&y);
            for(int j=0; j<y; j++)
            {
                cin>>s;
                mp[x][s]=x;
            }
        }
        map<string,int>::iterator it;
        for(int i=0; i<n; i++)
        {
            cin>>q[i];
            cout<<q[i];
            memset(t,0,sizeof t);
            for(int j=1; j<=m; j++)
            {
                it=mp[j].find(q[i]);
                if(it!=mp[j].end())
                {
                    book[i]++;
                    t[j]=(*it).second;
                }
            }
            printf(" %d",book[i]);
            for(int j=1; j<=m; j++)
            {
                if(t[j]!=0)
                    printf(" %d",t[j]);
            }
            printf("\n");
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值