PAT 1102 Invert a Binary Tree (25 分)

1102 Invert a Binary Tree (25 分)

The following is from Max Howell @twitter:

Google: 90% of our engineers use the software you wrote (Homebrew), but you can’t invert a binary tree on a whiteboard so fuck off.

Now it’s your turn to prove that YOU CAN invert a binary tree!


Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤10) which is the total number of nodes in the tree – and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node from 0 to N−1, and gives the indices of the left and right children of the node. If the child does not exist, a - will be put at the position. Any pair of children are separated by a space.


Output Specification:
For each test case, print in the first line the level-order, and then in the second line the in-order traversal sequences of the inverted tree. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:

8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6

Sample Output:

3 7 2 6 4 0 5 1
6 5 7 4 3 2 0 1




解析

这题用静态实现就挺好的。因为题目给的是结点编号之间的关系。把二叉树构建出来,其他都是常规了



Code:

#include<algorithm>
#include<cstdio>
#include<iostream>
#include<queue>
#include<string>
#include<vector>
using namespace std;
struct node {
	int data;
	int lchild, rchild;
	node(int value) :data(value), lchild(-1),rchild(-1){
	}
};
vector<int> in, layer;
vector<node*> Tree(20,nullptr);
bool notroot[20]{ false };
void layerorder(int root) {
	queue<int> q;
	q.push(root);
	while (!q.empty()) {
		int New = q.front();
		q.pop();
		layer.push_back(Tree[New]->data);
		if (Tree[New]->lchild != -1) q.push(Tree[New]->lchild);
		if (Tree[New]->rchild != -1) q.push(Tree[New]->rchild);
	}
}
void inorder(int root) {
	if (root == -1)
		return;
	inorder(Tree[root]->lchild);
	in.push_back(Tree[root]->data);
	inorder(Tree[root]->rchild);
}
void invert(int root) {
	if (root == -1)
		return;
	swap(Tree[root]->lchild, Tree[root]->rchild);
	invert(Tree[root]->lchild);
	invert(Tree[root]->rchild);
}
int main()
{
	int N;
	char node1, node2;
	scanf("%d", &N);
	getchar();
	for (int i = 0; i < 11; i++)
		Tree[i] = new node(i);
	for (int i = 0; i < N; i++) {
		scanf("%c %c", &node1, &node2);
		getchar();
		if (node1 != '-') {
			Tree[i]->lchild = node1-'0';
			notroot[node1 - '0'] = true;
		}
		if(node2 !='-'){
			Tree[i]->rchild = node2-'0';
			notroot[node2 - '0'] = true;
		}
	}
	int root;
	for (int i = 0; i < N; i++) {
		if (!notroot[i]) {
			root = i;
			break;
		}
	}
	invert(root);
	layerorder(root);
	inorder(root);
	for (int i = 0; i < N; i++)
		printf("%d%c", layer[i], i == N - 1 ? '\n' : ' ');
	for (int i = 0; i < N; i++)
		printf("%d%c", in[i], i == N - 1 ? '\n' : ' ');
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值