【PAT】1102. Invert a Binary Tree (25)【二叉树的中序遍历和层次遍历】

题目描述

The following is from Max Howell @twitter:

Google: 90% of our engineers use the software you wrote (Homebrew), but you can’t invert a binary tree on a whiteboard so fuck off.
Now it’s your turn to prove that YOU CAN invert a binary tree!

翻译:下面是来自Max Howell@twitter:
谷歌:我们90%的工程师使用你写的软件(Homebrew),但是你不能在白板上反转一个二叉树,所以滚蛋。
现在轮到你证明你可以反转一个二叉树了!

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10) which is the total number of nodes in the tree – and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node from 0 to N−1, and gives the indices of the left and right children of the node. If the child does not exist, a - will be put at the position. Any pair of children are separated by a space.

翻译:每个输入文件包含一组测试数据。对于每组输入数据,第一行包括一个正整数N(≤10) ,代表树上的总节点数–假设所有节点被标记为0到N-1。接下来N行,每行包括一个节点从0到N-1,并且给出该节点的左孩子和右孩子目录。如果孩子不存在,该位置将会用‘-’来代替。任何一对孩子之间用空格隔开。

Output Specification:

For each test case, print in the first line the level-order, and then in the second line the in-order traversal sequences of the inverted tree. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

翻译:对于每组输入数据,输出一行反转的树的层次遍历数列,并在第二行输出反转的树的中序遍历数列。两个相邻数字之间需要用一个空格隔开并且一行末尾不能有多余空格。


Sample Input:

8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6


Sample Output:

3 7 2 6 4 0 5 1
6 5 7 4 3 2 0 1


解题思路

保存节点的父亲,然后顺藤摸瓜找到根节点,再输出层次遍历和中序遍历。注意输出格式,和给出的样例进行比较。

#include<iostream>
#include<cstdio>
#include<string>
#include<cstring>
#include<cmath>
#include<cstdlib>
#include<vector> 
#include<queue>
#include<algorithm>
using namespace std;
int n;
int v[15][2];
int father[15];
int root=-1;
int findRoot(int node){
	if(father[node]==-1)return node;
	else findRoot(father[node]);
}
void levelOrder(int node){
	queue<int>q;
	q.push(root);
	int tflag=0;
	while(!q.empty()){
		int tmp=q.front();q.pop();
		if(!tflag)printf("%d",tmp),tflag=1;
		else printf(" %d",tmp);
		if(v[tmp][1]>=0)q.push(v[tmp][1]);
		if(v[tmp][0]>=0)q.push(v[tmp][0]);
	}
	printf("\n");
}
int ans[15],ccount=0;
int inOrder(int node){
	if(v[node][0]==-1);
	else inOrder(v[node][0]);
	ans[ccount++]=node;
	if(v[node][1]==-1);
	else inOrder(v[node][1]);
}
int main(){
	for(int i=0;i<15;i++)father[i]=-1;
	scanf("%d",&n);
	char a,b;
	for(int i=0;i<n;i++){
		scanf("\n%c %c",&a,&b);
		if(a=='-')v[i][0]=-1;
		else v[i][0]=a-'0',father[a-'0']=i;
		if(b=='-')v[i][1]=-1;
		else v[i][1]=b-'0',father[b-'0']=i;
	}
	root=findRoot(0);
	levelOrder(root);
	inOrder(root);
	for(int i=ccount-1;i>0;i--){
		printf("%d ",ans[i]);
	}
	printf("%d\n",ans[0]);
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值